Latest nightly build completely screws up the browser

VERIFIED DUPLICATE of bug 135222

Status

SeaMonkey
Installer
VERIFIED DUPLICATE of bug 135222
16 years ago
14 years ago

People

(Reporter: Philip White, Assigned: dveditz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
I am sure that my case is unique, but today I downloaded the latest nightly 
buld (2002040503) for Windows XP, closed my current browser and mail windows, 
chose Custom installation... the components window only offered one component, 
Personal Security Manager -- everything else was checked and ghosted.

After the installation completed, the browser window started opening, 
presumably to show me that Welcome webpage.  However, during the splash 
screen, it popped up an error message in Attachment 1 [details] [diff].

After I clicked okay, it opened the window portrayed in Attachment 2 [details] [diff]... I was 
waiting for about a minute, because I assumed that it was still loading all 
the widgets and stuff.  However, it finished at that blank screen.  The 
maximize and minimize buttons work.  The two icons on the right (lock and 
connection) are ineffective.  Clicking or double-clicking them does nothing.

Just now I opened the browser window again to test the buttons on the left -- 
this time it opened a blank window without any icons on the bottom at all.

However, if I open Mozilla Mail from the start menu, everything works just 
fine there.  I can read and send mail successfully.  The mail client has only 
ONE icon in the bottom-left corner, though -- the composer.  No browser, no 
chat client...

I am forced to use Microsoft Internet Explorer to submit this bug report.

---------------
I wasn't even sure which Browser component to refer this to... if what I've 
chosen is wrong, forgive me.
(Reporter)

Comment 1

16 years ago
Created attachment 78041 [details]
The pop-up message box during the splash screen
(Reporter)

Comment 2

16 years ago
Created attachment 78042 [details]
Browser window

Comment 3

16 years ago
this is a duplicate of bug 135222

thanks for the report.
uninstall mozilla and then reinstall it and the problem should disappear

*** This bug has been marked as a duplicate of 135222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Reporter:
Please look in the mozilla directory :
Are there old .Dll Files in mozilla\ and/or mozilla\components ?

Please list this files here.
This will fix comment #1.

After that uninstall mozilla/reinstall mozilla and mozilla should run again.
(comment #2 is bug 135222)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
-> Installer
Severity: blocker → normal
.
Assignee: seawood → dveditz
Component: Build Config → Installer
QA Contact: granrose → bugzilla
(Reporter)

Comment 7

16 years ago
A recursive search in C:\Program Files\Mozilla yields 127 DLL files.  I don't 
know which ones are "old".
(Reporter)

Comment 8

16 years ago
If I uninstall Mozilla and reinstall it, will it delete my bookmarks, 
preferences, and e-mail/newsgroup settings?
Are there any configuration files I should back up before uninstalling it?

Thanks for a quick response to my bug report.

Comment 9

16 years ago
No, uninstalling does not delete any profile information - it leaves bookmarks,
cache, email, address book, etc. alone.  I routinely back up my profile folder
before uninstall/reinstall, but this is just a bit of paranoia on my part - and
to protect against profile corruption which (rarely) occurs in some nightlies.
In XP, the profile directory should be C:\Documents and Settings\(user
name)\Application Data\Mozilla\Profiles\(profile name)\(string of gibberish
numbers and letters)
Where (user name) is your XP logon name, and (profile name) is your mozilla
profile name, and the gibberish is randomly generated. I copy this folder to
another location, then use control panel to uninstall, then reinstall.

Comment 10

16 years ago
remove old mozilla before installing new
dupe!

*** This bug has been marked as a duplicate of 135222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
This is not a dupe for the screenshot in comment #1.
But without a list of old files we can't do anything.

Comment 12

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.