Persist inspector sidebar accordion's states

RESOLVED FIXED in Firefox 55

Status

P3
enhancement
RESOLVED FIXED
2 years ago
6 months ago

People

(Reporter: pbro, Assigned: gl)

Tracking

unspecified
Firefox 55
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
There are 2 accordions in the inspector's sidebars: one in the computed tab, to hide/show the box-model, and one in the layout tab, to hide/show the box-model and the grid panel.

It would be great if these could persist their states, so you wouldn't have to constantly close the ones you don't care about.
(Reporter)

Comment 1

2 years ago
See Jen's feedback about this in bug 1345300 comment 6.
(Assignee)

Updated

2 years ago
Severity: normal → enhancement
Priority: -- → P3
(Reporter)

Updated

2 years ago
Blocks: 1347964
Assignee: nobody → tigleym
Assignee: tigleym → nobody
(Assignee)

Updated

2 years ago
Assignee: nobody → gl
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Reporter)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8873719 [details]
Bug 1359763 - Persist the box model and grid panel's accordion states.

https://reviewboard.mozilla.org/r/145116/#review149196

I tested this locally, works like a charm!
I honestly have nothing to say about the code changes here. If try is green, then I'm happy too.

Any thoughts about the following use case though: should the box model in the layout view be collapsed by default if there's a grid on the page?
I can see 2 problems with it: if we already persisted a state, not restoring it in this case would break the expectations. And All other accordions in the app are opened by default (I think).
Of course the idea behind doing something like is that if there's a grid and people are switching to the layout panel for the first time, and they have a rather tiny toolbox, they won't even see the grid section at all. 
Another approach: make the grid section first, and box model section second. Simple, but effective. Knowing that the box model is already in the computed view, maybe we can afford to do this.
Attachment #8873719 - Flags: review?(pbrosset) → review+

Comment 4

2 years ago
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/73a2ddbb89bc
Persist the box model and grid panel's accordion states. r=pbro

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/73a2ddbb89bc
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1369947
Because I have ideas that may become new actions to take, I opened a new ticket with my thoughts here: 
https://bugzilla.mozilla.org/show_bug.cgi?id=1370004
Depends on: 1369918

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.