TestHistory Unit Test failing occasionally

NEW
Unassigned

Status

()

Firefox for iOS
Build & Test
P3
normal
6 months ago
2 months ago

People

(Reporter: isabel_rios, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+, fxios-v8.0 affected)

Details

(Whiteboard: [MobileCore])

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Created attachment 8862002 [details] [review]
Link to Github pull-request: https://github.com/mozilla-mobile/firefox-ios/pull/2664

Under TestHistory test suite, this test is failing occasionally:

testRandomThreading2()

So far always seen with failure: Launch session expired
https://dashboard.buddybuild.com/apps/57bf25c0f096bc01001e21e0/build/58ffeb1723691b0001054ada/test/3a67eebc-781b-4bbd-b290-921a45cdfda7/2f55c863-014f-44a7-a58f-62c93bda27c5#tests
(Reporter)

Comment 1

6 months ago
Sorry, I do not know why that PR was attached here, but that is not correct, please ignore it
(Reporter)

Comment 2

6 months ago
Nomianting, it would require at least some investigations in case the recent failures seen are due to a regression that could cause problems in the future
status-fxios-v8.0: --- → affected
tracking-fxios: --- → ?
(Reporter)

Comment 3

6 months ago
Note: Failing both in Fennec and Nightly
tracking-fxios: ? → 8.0+
Priority: -- → P2
Whiteboard: [MobileCore]
See patch in Bug 1350977.
See Also: → bug 1350977
Isabel, can you check and see if the patch I just landed in Bug 1350977 helps fix this intermittent failure?
Flags: needinfo?(irios.mozilla)
(Reporter)

Comment 6

6 months ago
Sure, I will pay atention and look if the test failure can still be seen in any of the builds. Will keep this bug open till the test consistently pass.
Thanks!
(Reporter)

Comment 7

6 months ago
Justin, FYi, the test have failed again, please see build: https://dashboard.buddybuild.com/apps/57bf25c0f096bc01001e21e0/build/590b6f545419120001b2de78#tests

It is running a commit landed after the commit with the patch: 89a413fd722bd50ae4624615f8e8622f00254d12

It can be an isolated case, will keep monitoring it to see it the test fails again.
Flags: needinfo?(irios.mozilla)
tracking-fxios: 8.0+ → +

Comment 8

4 months ago
The test hasn't been failing for a while after landing another patch, so will close this.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Re-opening as this problem seems to be back:

https://dashboard.buddybuild.com/apps/57bf25c0f096bc01001e21e0/build/593ef07477614600011972f7/test/173231e6-a64b-4eb6-9a65-b42123e95334/11ed8e65-0062-41ed-8064-394dfd0c60de#tests
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → jdarcangelo
Status: REOPENED → ASSIGNED
Assignee: jdarcangelo → nobody
Status: ASSIGNED → NEW
Priority: P2 → P3
You need to log in before you can comment on or make changes to this bug.