Incorrect "last page visited" if don't close Quick Launch before exiting Windows

RESOLVED WORKSFORME

Status

()

Core
History: Global
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Sarah, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

I have set the Preferences so that the "last page visited" loads when I start
Navigator. However, if I don't close Mozilla Quick Launch before exiting or
logging off Windows, the last page I visited in the previous Mozilla session
doesn't load. Instead, the "last page visited" from whenever I last closed Quick
Launch displays instead. 

Reproducible: Always
Steps to Reproduce:
0. Quick Launch should be enabled.  
1. Start Mozilla Navigator. In Edit > Preferences under the Navigator tab, set
the "last page visited" to load when Navigator starts.
2. Browse the web and stop at a memorable page (eg.
http://users.aol.com/s6sj7gt/mikerav.htm). Remember this page - I'll call it
Site A. 
3. Exit Mozilla Navigator. (Note: If you start Mozilla up again before the next
step, Mozilla will load Site A as expected.)
4. Exit Mozilla completely by right-clicking on the Quick Launch icon and
choosing "Exit Mozilla." 
5. Log off Windows, then log right back in again. 
6. Start Mozilla Navigator (after Quick Launch has started itself). Mozilla
should load Site A, as expected. 
7. Browse the web some more and find another memorable page (eg.
http://www.madsci.org/). Remember this site - I'll call it Site B. 
8. Close Mozilla Navigator BUT DON'T fully close Mozilla (ie. don't exit Mozilla
via Quick Launch). (Note: If you start Mozilla up again before the next step,
Mozilla will load Site B as expected.)
9. Log off Windows, then log right back in again. 
10. Start Mozilla Navigator (after Quick Launch has started itself). Mozilla
will load Site A again, not Site B as expected. 


Actual Results:  See above - Site A loaded on startup. 

Expected Results:  Site B should have loaded on startup.

Comment 1

16 years ago
Great bug write up, but I can't reproduce this bug in Mozilla 1.0 Windows 98. I
admit that at step 7 I entered one different url before going on to step 8 but
your instructions are unclear as to whether you have to visit multiple sites
between steps (and whether you can just type in a different url to visit those
sites).

Reporter (Sarah), please can you check to see whether this bug is still present
in a recent build (Moz1-RC1 or a new nightly build). If this bug does not occur
please can you resolve it worksforme.

Comment 2

15 years ago
WFM with 2002092308/trunk/win2k (I get site B as expected).

no response from reporter for >30 days. resolving WFM.

reporter (Sarah): if you can reproduce this with a recent build of mozilla,
please reopen this bug. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.