[discuss] Blockers for generate Rust coverage on a nightly schedule

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: ekyle, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This bug is to discuss the delays and problems we may encounter in an effort to emit Rust coverage on a nightly schedule.
(Reporter)

Comment 1

2 years ago
For example, 

Changes to the Rust coverage collection is not realized by our CI for many weeks after landing: Delay is currently caused by Rust's beta testing cycle, and our own compiler upgrade schedule.
(Reporter)

Updated

2 years ago
Summary: [meta] Generate Rust coverage on a nightly schedule → [discuss] Blockers for generate Rust coverage on a nightly schedule
Rust 1.20.0 is now the stable version, so the GCOV profiling option is supported.
In order to actually use it, we just need to put a custom version of rustc with the profiling option enabled on tooltool (I've done this to generate the build in bug 1335518).

Other blockers are now blockers of bug 1335518.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.