1.57ms uninterruptible reflow at doFocus@chrome://global/content/bindings/popup.xml:334:13

RESOLVED FIXED in mozilla55

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
mozilla55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

(Reporter)

Description

2 years ago
Here's the stack:

doFocus@chrome://global/content/bindings/popup.xml:334:13
onxblpopuphidden@chrome://global/content/bindings/popup.xml:364:13
hidePopup@chrome://global/content/bindings/popup.xml:137:13
hidePanelForNode@resource:///modules/CustomizableUI.jsm:1651:7
hidePanelForNode@resource:///modules/CustomizableUI.jsm:3624:5
closePopup@resource:///modules/ExtensionPopups.jsm:548:7
receiveMessage@resource:///modules/ExtensionPopups.jsm:212:9
Flags: qe-verify?
Priority: -- → P2
Component: Untriaged → XUL Widgets
Depends on: 1356034
Product: Firefox → Toolkit
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Flags: qe-verify? → qe-verify-
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
I can no longer reproduce a reflow in this codepath since bug 1369140 landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Iteration: --- → 55.7 - Jun 12
Priority: P3 → P1
You need to log in before you can comment on or make changes to this bug.