Closed Bug 1360097 Opened 3 years ago Closed 3 years ago

Scroll bar not working in 53.0

Categories

(Core :: Panning and Zooming, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1341992

People

(Reporter: bekpekker, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749
Firefox for Android

Steps to reproduce:

Any web page where the vertical scroll bar shows.


Actual results:

Using a Windows 8.1 tablet I can click the scroll bar but nothing is happening when clicking, dragging or using the arrow keys.


Expected results:

The page should have moved up or down.
I see it is posted with the remark "Firefox for Android". That is not where I posted it. I'm using Windows 8.1. Please correct.
Component: Untriaged → Widget: Win32
Product: Firefox → Core
Component: Widget: Win32 → Panning and Zooming
This sounds a lot like bug 1341992. bekpekker, do you see this problem when using the mouse? or using a touch/pen input device? Or both? You also mentioned the arrow keys - are you referring to the arrow buttons on either end of the scrollbar?
Flags: needinfo?(bekpekker)
Yes it looks like the bug you mentioned. Just with a different OS, browser and in the 53 version. I visited the about:support page and noticed the scrollbar IS working on that page. However, on most web pages it isn't. The same goes for small scrollbars included in some web pages. And yes, I did mean the arrow keys on either end of the scrollbar. Unfortunately I don't have a mouse or pen with me on my travels to try. Sorry about that...

Tnx...
Flags: needinfo?(bekpekker)
By the way, degrading to 52.0 and/or disabling add-ons to create a workable situation unfortunately doesn't solve the problem. I guess I'm stuck with it.

Tnx again!
Ok, thanks. I'm going to mark this as a duplicate of bug 1341992. A workaround for now would be to go to about:config, set the dom.w3c_touch_events.enabled to 0 (it defaults to 2), and restart the browser. That should restore the behaviour to the way it was back in 51. However you will also lose the improved touch-scrolling behaviour that we introduced. Once we fix bug 1341992 you should be able to revert dom.w3c_touch_events.enabled back to 2.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341992
Thanks. I've set it to 0 and restarted but it doesn't do anything for the scroll bar though.
I see my response is only partly true: If I touch anywhere on the scrollable area the page will move. However, if I try to drag the bar itself (the most often used way) then it still doesn't work.

Tnx...
Hm, that's interesting. When dom.w3c_touch_events.enabled was set to 2, if you tried to scroll by touching on the scrollable area of the page, did it work?
Flags: needinfo?(bekpekker)
No I didn't. Only when set to 0.

Another thing I noticed (but may be expected) is that with the setting at 2 scrolling by sliding the page itself is extremely smooth and fast, and when the parameter is set to 0 it takes quite some effort and happens in shocks. This may be a new feature though so no comment at all.

Tnx!
Flags: needinfo?(bekpekker)
Ok, that's expected. I think I misunderstood what you meant earlier when you said "touch anywhere on the scrollable area". I thought you meant the scrollable area of the page (i.e. where the web content is displayed) but now I think you really meant the scrollbar track (the part between the up and down arrows in the scrollbar, excluding the thumb). So yes, this bug is a duplicate.
You need to log in before you can comment on or make changes to this bug.