Closed Bug 1360183 Opened 4 years ago Closed 4 years ago

Change Search Settings button not included in the navigation cycle of the Left/Right keys

Categories

(Firefox :: Search, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: simona.marcu, Unassigned)

References

Details

(Whiteboard: [fxsearch])

Mozilla/5.0 (Windows NT 10.0; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170426030329

[Affected versions]:
- Nightly 55.0a1

[Affected platforms]:
- All

[Steps to reproduce]:
1. Launch Firefox
2. Write something in the Search Bar
3. Press Down key to reach to the first one-off button
4. Press Righ/Left key until the first add-on is selected again

[Expected result]: 
- Left and Right keys should cycle through the one-offs including the Change Search Settings button.(at least this is the behavior in the one-off bar in the Awesome bar)

[Actual result]:
- Change Search Settings button is not included in the navigation cycle when Left and Right keys are used.
I think this is intended. In the awesomebar the behavior is different because the settings button is on the same line as the one-off buttons.
Thanks Florian. Drew do you concur that this is a wontfix or do we need to ask shorlander?
Flags: needinfo?(adw)
Whiteboard: [fxsearch]
Summary: Change Search button not included in the navigation cycle of the Left/Right keys → Change Search Settings button not included in the navigation cycle of the Left/Right keys
Yes, that's the intended behavior.  In the urlbar, the settings button is treated like a search button in this case (presumably since it's basically the same size and on the same line).  In the search bar, it's treated as a separate kind of button.

I'll mark this wontfix, but thanks for filing this, Simona.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(adw)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.