INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INVALID
17 years ago
8 years ago

People

(Reporter: Steven Augart, Assigned: Joe Chou)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I am running Mozilla 0.9.9 on Linux, the default installer build.

After generating the above error about the Exec of "java_vm" failed, Mozilla stopped
being responsive.  Windows take on whatever image and text the windows that most recently were on top of them had.

The stack for the main thread looks like this after the hang:

(gdb) bt
#0  0x40570c87 in poll () from /lib/libc.so.6
#1  0x401e1288 in PRP_NakedBroadcast () from /usr/local/mozilla/libnspr4.so
#2  0x401e14bd in PRP_NakedBroadcast () from /usr/local/mozilla/libnspr4.so
#3  0x401e25a3 in PR_GetConnectStatus () from /usr/local/mozilla/libnspr4.so
#4  0x401e25ea in PR_GetConnectStatus () from /usr/local/mozilla/libnspr4.so
#5  0x401cfdbd in PR_Read () from /usr/local/mozilla/libnspr4.so
#6  0x40f35f24 in JavaVM5::StartJavaVM ()
   from /usr/local/mozilla-0.9.9-from-installer/plugins/libjavaplugin_oji.so
#7  0x40f34142 in JavaPluginFactory5::StartupJVM ()
   from /usr/local/mozilla-0.9.9-from-installer/plugins/libjavaplugin_oji.so
#8  0x40f33bfe in JavaPluginFactory5::GetJavaVM ()
   from /usr/local/mozilla-0.9.9-from-installer/plugins/libjavaplugin_oji.so
#9  0x40f34521 in JavaPluginFactory5::CreateSecureEnv ()
   from /usr/local/mozilla-0.9.9-from-installer/plugins/libjavaplugin_oji.so
#10 0x40e4e6e8 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/liboji.so
#11 0x40e4e75e in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/liboji.so
#12 0x40e4b324 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/liboji.so
#13 0x40e4bdb1 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/liboji.so
#14 0x40e6cbe2 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgkplugin.so
#15 0x40e6be4e in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgkplugin.so
#16 0x4112ffba in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#17 0x4112f292 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#18 0x4112a0b7 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#19 0x4110039c in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#20 0x411001d9 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#21 0x4110003f in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#22 0x410ffeeb in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#23 0x410fea18 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#24 0x410fe1e5 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#25 0x410fcbb0 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#26 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#27 0x411afc35 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#28 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#29 0x411c64d4 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#30 0x411c71b6 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#31 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#32 0x411c8794 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#33 0x411ca014 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#34 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#35 0x411b7f7e in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#36 0x411b55c4 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#37 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#38 0x411c25ee in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#39 0x411c42a7 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#40 0x41103f5a in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#41 0x41103ab6 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#42 0x410ff7ae in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#43 0x410fe66b in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#44 0x410fe1e5 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#45 0x410fcbb0 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#46 0x41103f5a in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#47 0x41103ab6 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#48 0x410ff7ae in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#49 0x410fe66b in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#50 0x410fe1e5 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#51 0x410fcbb0 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#52 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#53 0x4111909d in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#54 0x411e3e72 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#55 0x411e3a2b in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#56 0x411e0ef8 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#57 0x411cce81 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#58 0x411e0ef8 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#59 0x411e5a25 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#60 0x411160ea in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#61 0x411163f3 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#62 0x4111612b in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#63 0x411e0ef8 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#64 0x411f21f2 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#65 0x411158cc in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#66 0x411095db in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#67 0x41158097 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#68 0x411197b1 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#69 0x41144007 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#70 0x411441b8 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#71 0x41143dbb in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libgklayout.so
#72 0x40167d57 in PL_HandleEvent () from /usr/local/mozilla/libxpcom.so
#73 0x40167c73 in PL_ProcessPendingEvents ()
   from /usr/local/mozilla/libxpcom.so
#74 0x40168ba8 in nsEventQueueImpl::ProcessPendingEvents ()
   from /usr/local/mozilla/libxpcom.so
#75 0x40c991e3 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libwidget_gtk.so
#76 0x40c98f5d in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libwidget_gtk.so
#77 0x403913b0 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#78 0x40392c46 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#79 0x40393273 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#80 0x4039343c in g_main_run () from /usr/lib/libglib-1.2.so.0
#81 0x402ab96c in gtk_main () from /usr/lib/libgtk-1.2.so.0
#82 0x40c99674 in NSGetModule ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libwidget_gtk.so
#83 0x40c78aa6 in fullsoft_copyright ()
   from /usr/local/mozilla-0.9.9-from-installer/components/libnsappshell.so
#84 0x0804fe89 in main1 ()
#85 0x080506d7 in main ()
#86 0x404bd7ee in __libc_start_main () from /lib/libc.so.6
Reporter:
Have you symlinked the plugin ?
(Don't copy it because Java can't find the JVM)
Summary: INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2 → INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2

Comment 2

17 years ago
Likely to be incorrect plugin installation.
(Reporter)

Comment 3

17 years ago
Matti Versen:  Thanks for the suggestion.  The problem happened with a copied
plugin (not symlinked).  After posting the bug report, I did convert over to a
symlink, and things worked fine.

However, I left the bug report standing because the real problem -- as I see it
-- is that Mozilla began freezing up under this situation.  I believe that
the browser shouldn't lock up like this, when (to me) the obviously right thing
to do is to pop up a window saying "Trouble with your JAva setup! ", and go on
as best it can.

invalid

see http://bugzilla.mozilla.org/show_bug.cgi?id=135369#c11 for more informations
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.