Parse JavaScript explicitly/automatically when being cached in a Service Worker

RESOLVED DUPLICATE of bug 1350367

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1350367
a year ago
a year ago

People

(Reporter: Harald, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf])

(Reporter)

Description

a year ago
Problem: Parsing a major overhead for today's SPA's and major websites don't expect to reduce their JS sizes in the future.

Possible solution: Make Service Workers smarters and parse JS when it is fetched and added to the cache. This moves the parsing overhead off-thread and off the critical rendering path.

Chrome's summary (shared Google-externally): https://docs.google.com/document/d/1d8EeIY7nWpVT7yyofyqQuy57rQEf4Ft0s0virCSxUWI/edit#heading=h.4fos0lptaaag

Prior art: Chrome already caches bytecode for scripts that it sees at least twice a day: https://v8project.blogspot.com/2015/07/code-caching.html

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1350367
You need to log in before you can comment on or make changes to this bug.