Closed Bug 1360314 Opened 4 years ago Closed 4 years ago

Tree Style Tabs add-on inserts all lazy browsers on startup

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jryans, Unassigned)

References

Details

[bug 1345098] Lazy browser prematurely inserted via 'messageManager' property access:
getter@chrome://browser/content/tabbrowser.xml:2115:45
CB_sendAsyncCommand@resource://treestyletab-modules/contentBridge.js:101:7
AHB_notifyStatusToTab@resource://treestyletab-modules/autoHide.js:485:3
TSTBrowser_initTab@resource://treestyletab-modules/browser.js:1183:3
TSTBrowser_onTabOpen@resource://treestyletab-modules/browser.js:3310:3
TSTBrowser_handleEvent@resource://treestyletab-modules/browser.js:3044:12
addTab@chrome://browser/content/tabbrowser.xml:2400:13
ssi_restoreWindow@resource:///modules/sessionstore/SessionStore.jsm:3309:33
ssi_restoreWindows@resource:///modules/sessionstore/SessionStore.jsm:3542:5
initializeWindow@resource:///modules/sessionstore/SessionStore.jsm:1170:11
onBeforeBrowserWindowShown/<@resource:///modules/sessionstore/SessionStore.jsm:1319:9
process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:922:23
walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:806:7
Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:739:11
schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:770:7
Promise.prototype.then@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:455:5
TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:396:7
TaskImpl_run@resource://gre/modules/Task.jsm:327:15
TaskImpl@resource://gre/modules/Task.jsm:277:3
asyncFunction@resource://gre/modules/Task.jsm:252:14
getUserAccountData@resource://gre/modules/FxAccounts.jsm:164:12
getSignedInUser@resource://gre/modules/FxAccounts.jsm:517:12
_needsSetup@chrome://browser/content/browser-syncui.js:100:12
_promiseUpdateUI@chrome://browser/content/browser-syncui.js:143:12
updateUI@chrome://browser/content/browser-syncui.js:136:5
init@chrome://browser/content/browser-syncui.js:57:5
_delayedStartup@chrome://browser/content/browser.js:1510:5
TSTWH_preInit/gBrowserInit._delayedStartup@chrome://treestyletab/content/windowHelper.js:18:73
EventListener.handleEvent*onLoad@chrome://browser/content/browser.js:1239:5
onload@chrome://browser/content/browser.xul:1:1
By this commit, now TST does't touch to <browser>.messageManager anymore.
https://github.com/piroor/treestyletab/commit/03c99b3f656b265610e2b520689b8ebb5d996b81

I still see "Lazy browser prematurely inserted via ..." warning but it seems caused by Firefox's "_delayedStartup" itself.
(In reply to YUKI "Piro" Hiroshi from comment #1)
> By this commit, now TST does't touch to <browser>.messageManager anymore.
> https://github.com/piroor/treestyletab/commit/
> 03c99b3f656b265610e2b520689b8ebb5d996b81
> 
> I still see "Lazy browser prematurely inserted via ..." warning but it seems
> caused by Firefox's "_delayedStartup" itself.

Can you post the entire message including stack trace please?
Flags: needinfo?(yuki)
Hmm, it doesn't appear anymore on Nightly 55.0a1 20170430030208 on Windows 7.
Flags: needinfo?(yuki)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.