Need keyboard shortcuts for Fill In Form and Save Form Data commands.

VERIFIED DUPLICATE of bug 143881

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 143881
16 years ago
10 years ago

People

(Reporter: Jason Bassford, Assigned: Stephen P. Morse)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020405
BuildID:    2002040503

With the new context menus, the Prefill/Fill In Form command was taken out of
the right-click menus.  While it still exists in the main menu, it's more
cumbersome and time consuming to use that way.  A simple right-click in a form
field followed by a left click was far simpler than having to mouse up to Tools
-> Form Manager -> Fill In Form.  (I would say it takes about 3-4 times as long
to execute the command via the main menu.)  Since arguments over putting this
command back into a form right-click menu seem hopeless (bug 135750), I'd like
to suggest adding a keyboard shortcut to Prefill/Fill In Form instead.  This
method would be just as, if not more, convenient than the old method.

Reproducible: Always

Comment 1

16 years ago
I've submitted bug 135919, setting this as a blocker of 125919. Probably it
would make sense to resolve this as a duplicate of 135919?
Blocks: 135919
(Reporter)

Comment 2

16 years ago
Your bug seems to be a duplicate of one I filed (bug 135750).  I doubt you'll
find any luck getting Fill In Form reinstated to the context menus.  (Just read
the discussion that went on in my bug!)

However, Asa's mentioned in MozillaZine that you can simply double-click in a
form field in order to use that menu command.  This is even better than having
it in the context menus.  Why this was never mentioned in any of the discussion
of these related bugs is beyond me - but it alleviates my personal need for
either the context menu or a keyboard shortcut.

Hence, I'm resolving this bug as FIXED.  If anybody feels that there should be a
keyboard shortcut in addition to a double-click I'll reopen it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
fixed implies that it was broken, which it wasn't. Please use WONTFIX for such
cases in future.

VERIFIED WONTFIX
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
not fixed
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 5

16 years ago
I think Jason meant to wontfix this bug.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

16 years ago
Wow, what a mess.

First of all, I don't see why bug 135919 necessarily depends on this one.  A
keyboard shortcut is one possible way of having an obvious method of prefilling
a form, not the only one I can think of.

Secondly, it turns out that double-click prefills only the form field clicked
on, NOT the whole form.  So double-clicking, while better than nothing, is still
not a complete fix for this bug.

Reopening.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Updated

16 years ago
No longer blocks: 135919
(Reporter)

Comment 7

16 years ago
And removing dependency.
(Reporter)

Comment 8

16 years ago
Modifying Summary to include keyboard shortcut for Save Form Data also, as per
comments in bug 136037.  It's obvious that there's an interest in replacing all
of the lost context menu commands with keyboard shortcuts.
Summary: Need keyboard shortcut for Prefill/Fill In Form command. → Need keyboard shortcuts for Fill In Form and Save Form Data commands.
(Reporter)

Comment 9

16 years ago
Correction: As per comments in bug 135919.  (I wish there were a way of
cancelling a post.)  Sorry for the spam.

Comment 10

16 years ago
-> morse
Assignee: blaker → morse
Status: REOPENED → NEW
Component: XP Apps: GUI Features → Form Manager
QA Contact: paw → tpreston

Comment 11

16 years ago
One more comment that makes need for right-click form menu more important - how
to manage forms in pop up windows, that open with no menu?? Clicking on field
seems to be not working, I get no prefill options...
(Assignee)

Comment 12

16 years ago

*** This bug has been marked as a duplicate of 143881 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 13

15 years ago
Verifying resolution of all bugs I've reported.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
You need to log in before you can comment on or make changes to this bug.