Can not use PreventDefault for keydown event when typing Hangul

RESOLVED DUPLICATE of bug 1259692

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 1259692
9 months ago
8 months ago

People

(Reporter: dapsdh, Unassigned)

Tracking

({intl})

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8862726 [details]
test_hangul_prevent_default.html

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

1. Write JS code to preventDefault on keydown event.
2. In Microsoft IME, set to Hangul mode and enter Hangul.
3. Letters appear.


Actual results:

When I test it in English, I can not see the letter. Hangul should not be displayed like English.


Expected results:

When typing in English, the characters are not displayed when keydown.preventDefault is used. In Hangul mode, there is a need for a method that can prevent characters from being displayed. 
In version 53, when intl.tsf is enabled, the keydown event itself does not occur in Korean IME mode. If intl.tsf is disabled, keydown.preventDefault does not work even if keydown event occurs, so Hangul is still displayed.

Updated

9 months ago
Component: Untriaged → DOM: Events
Keywords: intl
Product: Firefox → Core
Could this be the same issue as Bug 865564? Do you know, Masayuki?
Flags: needinfo?(masayuki)
No. If this is reproducible only in TSF mode, this is a dup of bug 1259692. Otherwise, bug 354358.
Flags: needinfo?(masayuki)
Reporter, can you look at the bugs mentioned in comment 2 to see if this has already been reported? Thank you.
Flags: needinfo?(dapsdh)
(Reporter)

Comment 4

8 months ago
It is associated with bug 1259692, but it does not exactly match the reported problem. For example, Chrome has a bug where keydown.preventDefault does not work when typing Hangul, even though a keydown event occurs, so I am reporting and waiting for the issue.(https://bugs.chromium.org/p/chromium/issues/detail?id=706672)
Flags: needinfo?(dapsdh)
I'm inclined to mark this a dupe of bug 1259692 and kindly ask you to open a new bug for the separate issue related your second sentence in comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(dapsdh)
Resolution: --- → DUPLICATE
Duplicate of bug: 1259692
(Reporter)

Comment 6

8 months ago
Newly registered as Bug 1364282.
Flags: needinfo?(dapsdh)
You need to log in before you can comment on or make changes to this bug.