Closed Bug 1360463 Opened 4 years ago Closed 4 years ago

Item under column heading have been slightly moved to right

Categories

(Thunderbird :: Folder and Message Lists, defect)

53 Branch
All
Linux
defect
Not set
normal

Tracking

(thunderbird_esr5254+ fixed, thunderbird53 wontfix, thunderbird54 fixed, thunderbird55 fixed)

RESOLVED FIXED
Thunderbird 55.0
Tracking Status
thunderbird_esr52 54+ fixed
thunderbird53 --- wontfix
thunderbird54 --- fixed
thunderbird55 --- fixed

People

(Reporter: ovari123, Assigned: Paenglab)

References

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170421105455

Steps to reproduce:

Items under column heading all moved slightly to the right. This seems appropriate when an image is placed there, like in the Subject column there can be Reply/Forward/Redirect image.

Does not seem correct to have the items moved slightly to the right under column headings: Received, Date, Status.

Thank you

Linux Mint 18.1 Cinnamon 64-bit
Thunderbird 53.0b2 (64-bit)
On windows and the daily version it's not the same
I think this move should not apply to checkboxes cells
Attached patch Bug1360463.patchSplinter Review
This is a regression of bug 1354263. Unfortunately folderPane.css affects also the threadPane.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8863144 - Flags: review?(acelists)
Comment on attachment 8863144 [details] [diff] [review]
Bug1360463.patch

Review of attachment 8863144 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8863144 - Flags: review?(acelists) → review+
Keywords: checkin-needed
OS: Unspecified → Linux
Hardware: Unspecified → All
https://hg.mozilla.org/comm-central/rev/3629bdd18f2e534f2d2f3b3fe29d945e2a230abe
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
Comment on attachment 8863144 [details] [diff] [review]
Bug1360463.patch

[Approval Request Comment]
Regression caused by (bug #): 1354263
User impact if declined: too much whitespace before the text in the threadPane
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8863144 - Flags: approval-comm-esr52?
Attachment #8863144 - Flags: approval-comm-beta?
Attachment #8863144 - Flags: approval-comm-beta? → approval-comm-beta+
This change breaks the feed subscribe dialog tree.
Ah yes, sorry.
Attachment #8863253 - Flags: review?(alta88)
Comment on attachment 8863253 [details] [diff] [review]
subscriptions.patch

Wouldn't it be better to not have linux diverge from win/osx unnecessarily (in either folderPane.css or feed-subscriptions.css? I realize the regressing bug was done for GTK, but perhaps there's a way to make them all the same.

Just a suggestion, the patch does fix the immediate problem..
Attachment #8863253 - Flags: review?(alta88) → review+
Comment on attachment 8863253 [details] [diff] [review]
subscriptions.patch

[Approval Request Comment]
Additional patch to fix the icons in subscription dialog
Attachment #8863253 - Flags: approval-comm-esr52?
Attachment #8863253 - Flags: approval-comm-beta?
Does the patch also fix the selected option shown in the “Folder Pane Toolbar” on Linux Mint?
Sorry, I don't understand what you mean.
Attached image Folder Pane Toolbar.png
(In reply to Richard Marti (:Paenglab) from comment #13)
> Sorry, I don't understand what you mean.

Menu Bar → View → Toolbars → Folder Pane Toolbar (enabled)

Attached image shows the “Folder Pane Toolbar” with “All Folders” selected; however, it is also been slightly moved to the right on Linux. On Windows it is shown correctly.
Ovari123, please can you file a bug, it's not fixed.
(In reply to Richard Marti (:Paenglab) from comment #15)
> Ovari123, please can you file a bug, it's not fixed.

Bug 1361157
Component: Untriaged → Folder and Message Lists
Attachment #8863253 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1365557
Attachment #8863144 - Flags: approval-comm-esr52? → approval-comm-esr52+
Attachment #8863253 - Flags: approval-comm-esr52? → approval-comm-esr52+
Attached image Spacing in message list
Hopefully constructive for all who don’t want to wait until version Thunderbird 55. You can fix this issue temporarily by adding a CSS rule to the userChrome.css file:

/* Spacing fix until Thunderbird 55 */
treechildren::-moz-tree-image {
   width: inherit !important;
   height: inherit !important;
}

For clarification I’ve attached a screenshot what spacing we are talking about (unwanted spacing in purple).
You need to log in before you can comment on or make changes to this bug.