Closed Bug 1360608 Opened 3 years ago Closed 3 years ago

9.38 - 11.42% sessionrestore / sessionrestore_no_auto_restore (osx-10-10) regression on push 1ad211b75475 (Wed Apr 26 2017)

Categories

(Core :: Graphics, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression, Whiteboard: [qf])

Talos has detected a Firefox performance regression from push 1ad211b75475:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=02673f6ec65e32c1fcd12d3551eac066fe259d9e&tochange=1ad211b754753afad6daa0b595dc0837c14fb5b7

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 11%  sessionrestore_no_auto_restore osx-10-10 opt e10s     940.75 -> 1048.17
  9%  sessionrestore osx-10-10 opt e10s                     907.58 -> 992.75


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=6231

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:gerald, I see you landed the patch from bug 1337062 yesterday, this sems to have caused a noticeable regression for OSX in sessionrestore tests.

Can you take a look at this and determine what is going on and if there is anything we can do to fix the regression or reduce it?
Component: Untriaged → Graphics
Flags: needinfo?(gsquelart)
Product: Firefox → Core
Good news I guess: Bug 1337062 was backed-out because of intermittent test failures (see bug 1337062 comment 69.)

Though we may want to keep this bug open, to first monitor the drop (hopefully) after the backout, and as a reminder about Talos issues before we try landing again...
Flags: needinfo?(gsquelart)
Looking at the same graph from the alert, the drop is already visible! And it corresponds to the backout check-in.
the backout shows the improvement we were looking for:
== Change summary for alert #6288 (as of April 29 2017 04:56 UTC) ==

Improvements:

 10%  sessionrestore osx-10-10 opt e10s     1011.67 -> 906.17
 10%  sessionrestore_no_auto_restore osx-10-10 opt e10s1037.83 -> 933.58

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=6288
We should track Talos sessionrestore regressions for Quantum Flow.
Whiteboard: [qf]
Joel, is there anything more to do here?  It seems like the backout gave us our perf back?  :-)
Flags: needinfo?(jmaher)
nothing to do here, I left this open as per comment 2, :gerald, should we close this?
Flags: needinfo?(jmaher) → needinfo?(gsquelart)
All good now, thanks Joel for monitoring Talos.

Marking as fixed thanks to the backout in bug 1337062 comment 69.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gsquelart)
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.