drag and drop in Bookmarks menu creates duplicate entries

RESOLVED DUPLICATE of bug 109640

Status

--
major
RESOLVED DUPLICATE of bug 109640
17 years ago
14 years ago

People

(Reporter: tgifriday1969, Assigned: bugs)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to create problem:
1) Created a folder in IE Favorites called Software Updates which is empty. 
2) Updated mozilla which imported IE Favorites.
3) Created a bookmark by dragging URL to Bookmarks menu and tried to put it in
Software Updates folder. When I tried to drag the link over the folder, it
wouldn't open to drop the link into.
4) Dropped the link on top of the Software Updates folder.
5) Instead of creating a link inside the folder, mozilla created a file link
called Software Updates in the same level as the folder.
6) Now whenever I try to reorder any of the folders or links using the Bookmarks
menu, I get another link entry called Software Updates in the same level as I am
doing the reordering regardless of whichever link/folder I try to reorder.

The Bookmarks sidebar does not have this behavior, only the Bookmarks menu.

Comment 1

17 years ago
Related to Bug 109640.
(Reporter)

Comment 2

17 years ago
This would be a duplicate of 109640, but when I reorder links it creates a
bookmark from the original folder called 'Software Updates' regardless of
whichever folders/bookmarks are involved in the reordering.

Oddly enough, I have noticed that the Bookmarks sidebar shows only one invalid
entry in each level it created duplicates, but the Bookmarks menu shows multiple
entries depending on how many times I tried to reorder.  This may be another bug
since the menu and sidebar should show the same thing.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 109640 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
oops, sorry
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
Rob, does restarting Mozilla solve this problem (deletes the extra entries, 
prevents this bug from happening again)?
(Reporter)

Comment 6

17 years ago
Yes, restarting removed all the invalid links.

Reordering worked fine again until I tried to reorder a folder again.  After
that, then all attempts to reorder thereafter create another bookmark of the folder.

Marking as a duplicate of bug#109640



*** This bug has been marked as a duplicate of 109640 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.