If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Archive in wrong place messages from Feed/RSS-accounts

RESOLVED FIXED in Thunderbird 55.0

Status

MailNews Core
Feed Reader
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: Nick, Assigned: alta88)

Tracking

Thunderbird 55.0

Thunderbird Tracking Flags

(thunderbird_esr52 unaffected, thunderbird54 fixed, thunderbird55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170418122848

Steps to reproduce:

Xubuntu 17.04-64
Thunderbird 54.0~b1+build1-0ubuntu0.17.04.1 from LP-PPA-mozillateam-thunderbird-next

Try to archive some messages in Input-folder of RSS-account.


Actual results:

Instead of archive in Archive-folder in this RSS-account messages appear in Archive-folder in first mail-account.


Expected results:

In version 53.0~b2 all was OK.

Updated

5 months ago
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core
Summary: Archive in wrong place messages from RSS-accounts → Archive in wrong place messages from Feed/RSS-accounts
Version: 54 Branch → 54
(Assignee)

Updated

5 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360858
(Assignee)

Comment 2

5 months ago
Created attachment 8864311 [details] [diff] [review]
feedarchive.patch


It turns out an unrelated default identity is returned, when unwanted, for a feed message when archiving. Fix bug 1343304.
Assignee: nobody → alta88
Status: RESOLVED → REOPENED
Ever confirmed: true
Attachment #8864311 - Flags: review?(mkmelin+mozilla)
Resolution: DUPLICATE → ---

Comment 3

5 months ago
Comment on attachment 8864311 [details] [diff] [review]
feedarchive.patch

Review of attachment 8864311 [details] [diff] [review]:
-----------------------------------------------------------------

Works great, thx! r=mkmelin
Attachment #8864311 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

5 months ago
Keywords: checkin-needed

Comment 4

5 months ago
https://hg.mozilla.org/comm-central/rev/da9448c4bf4f25d4b3a7aabed34576958f8ce2fa

Uplift to TB 54 beta?
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 55.0

Updated

5 months ago
Status: REOPENED → RESOLVED
Last Resolved: 5 months ago5 months ago
Resolution: --- → FIXED

Comment 5

4 months ago
Comment on attachment 8864311 [details] [diff] [review]
feedarchive.patch

Looks like a follow-up of bug 1343304, so I'll uplift this to beta 54.
Attachment #8864311 - Flags: approval-comm-beta+

Comment 6

4 months ago
Beta (TB 54):
https://hg.mozilla.org/releases/comm-beta/rev/1e786b7af184d759aa3b90dcc8f4c8198621dd43
status-thunderbird54: --- → fixed
status-thunderbird55: --- → fixed
status-thunderbird_esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.