cache files truncated, page is empty

VERIFIED DUPLICATE of bug 76431

Status

()

Core
Networking: Cache
P1
critical
VERIFIED DUPLICATE of bug 76431
16 years ago
16 years ago

People

(Reporter: Darin Fisher, Assigned: Darin Fisher)

Tracking

({regression, topembed})

Trunk
mozilla1.0
x86
Windows 2000
regression, topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
w/ the 2002040608 win2k build, i've noticed a lot of pages showing up empty. 
they stay empty unless i do a shift-reload.  after inspecting my cache files a
bit, i noticed that the cache entries report a non-zero data size, but the
corresponding data files are completely empty.  it seems that cache files are
getting truncated somehow.

investigating since i can repro this very easily...
(Assignee)

Updated

16 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: mozilla1.0, nsbeta1, regression, topembed
Priority: -- → P1
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 1

16 years ago
Created attachment 78140 [details]
zipped up Cache directory

i've zipped up my cache directory (500k compressed) in case we want to poke at
it some more.
I've noticed this happen if I run two builds with the same profile accidentally.
I have to clear the cache to get it to work again.

Is this because 0-length files are now valid, so we don't ignore them any more?
(Assignee)

Comment 3

16 years ago
yeah, in fact, this was because of the fact that i ran a netscape commercial
build along side a mozilla build... using the same profile.  i don't know how i
missed that fact when i went to file this bug :(

must have been the thera-flu ;-)

*** This bug has been marked as a duplicate of 76431 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.