Destroying the worker causes the virtual address space to leak, which sooner or later leads to a Firefox crash

RESOLVED DUPLICATE of bug 1377738

Status

()

Core
DOM: Workers
P2
normal
RESOLVED DUPLICATE of bug 1377738
9 months ago
6 months ago

People

(Reporter: CoolCmd, Assigned: baku)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P1])

Attachments

(2 attachments)

(Reporter)

Description

9 months ago
Created attachment 8863322 [details]
coolcmd.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

Run attached coolcmd.html.
Open the "Process Explorer" utility (https://technet.microsoft.com/en-us/sysinternals/processexplorer.aspx), open properties of the Firefox's content process, watch for "Virtual Size" parameter.


Actual results:

"Virtual Size" is unconditionally grows.
See the attached coolcmd.png. Red graph - working set, brown - virtual size.


Expected results:

"Virtual Size" should not unconditionally grow.
(Reporter)

Comment 1

9 months ago
Created attachment 8863323 [details]
coolcmd.png

Updated

9 months ago
Component: Untriaged → DOM: Workers
Product: Firefox → Core
(Reporter)

Updated

9 months ago
Summary: Destroying the worker causes the virtual space to leak, which sooner or later leads to a Firefox crash → Destroying the worker causes the virtual address space to leak, which sooner or later leads to a Firefox crash

Updated

9 months ago
Whiteboard: [MemShrink]
Whiteboard: [MemShrink] → [MemShrink:P1]
baku, can you take a look here, please?
Flags: needinfo?(amarchesini)
Priority: -- → P2
(Assignee)

Updated

9 months ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)

Comment 3

6 months ago
CoolCMD, can you reproduce this in latest nightly after bug 1377738 was fixed
(Reporter)

Comment 4

6 months ago
(In reply to Danial Horton from comment #3)
> CoolCMD, can you reproduce this in latest nightly after bug 1377738 was fixed

Nightly 56.0a1 Build ID 20170719030206
I can not reproduce my bug. Most likely it is fixed, possibly in bug 1377738.

Comment 5

6 months ago
Going to go ahead and dupe this based on comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1377738
You need to log in before you can comment on or make changes to this bug.