webrender_traits fails to compile with rust 1.17 from homebrew

RESOLVED INVALID

Status

()

Core
Graphics: WebRender
P2
normal
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: drno, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

a year ago
6:11.72 make[5]: Entering directory `/Users/nohlmeier/src/mozilla-central/objdir-x86_64-apple/toolkit/library/rust'
 6:12.49    Compiling nserror v0.1.0 (file:///Users/nohlmeier/src/mozilla-central/xpcom/rust/nserror)
 6:12.50    Compiling webrender_traits v0.36.0 (file:///Users/nohlmeier/src/mozilla-central/gfx/webrender_traits)
 6:12.88 error: proc-macro derive panicked
 6:12.88   --> /Users/nohlmeier/src/mozilla-central/gfx/webrender_traits/src/api.rs:20:30
 6:12.88    |
 6:12.88 20 | #[derive(Clone, Deserialize, Serialize)]
 6:12.89    |                              ^^^^^^^^^
 6:12.91    |
 6:12.91    = help: message: proc_macro::__internal::with_parse_sess() called before set_parse_sess()!
 6:12.91 
 6:12.91 error: Could not compile `webrender_traits`.
 6:12.91 Build failed, waiting for other jobs to finish...
 6:13.12 BUILDSTATUS OBJECT_FILE transportlayerdtls.o
 6:13.19 error: build failed
 6:13.20 make[5]: *** [force-cargo-library-build] Error 101

And yes it compiles fine if I manually switch rust back to 1.16.
It compiles with rustc 1.17.0 (56124baa9 2017-04-24) for me.
(Reporter)

Comment 2

a year ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> It compiles with rustc 1.17.0 (56124baa9 2017-04-24) for me.

Interesting. That explains why I'm the first to report this.

So I'm using rust on Mac OSX, installed via homebrew. After doing this:

  brew switch rust 1.16.0

The build worked finished successfully.

So maybe it's "only" a problem with rust 1.17.0 from homebrew?
(Reporter)

Updated

a year ago
Priority: P1 → P2
(Reporter)

Comment 3

a year ago
Apparently an issue caused by rust installed via homebrew: https://github.com/rust-lang/rust/issues/39870
(Reporter)

Updated

a year ago
Summary: webrender_traits fails to compile with rust 1.17 → webrender_traits fails to compile with rust 1.17 from homebrew

Updated

a year ago
Whiteboard: [gfx-noted]
I'm not sure there's value in keeping this bug open, as it's a bug in homebrew/rust. Any objections to closing it as invalid, since it's not a webrender/gecko bug?
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.