_findActivityObject should use a Map

RESOLVED DUPLICATE of bug 1361140

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED DUPLICATE of bug 1361140
a year ago
a year ago

People

(Reporter: jryans, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

From bug 1361140 with Browser Console open:

- _findActivityObject dominates the profile: https://perfht.ml/2p2cjx7 45% / 1800ms of CPU spent in it. Looking at the code (http://searchfox.org/mozilla-central/rev/3dc6ceb42746ab40f1441e1e659ffb8f62ae78e3/devtools/shared/webconsole/network-monitor.js#1180) shows this is an inefficient loop that should be replaced with a map.
(Reporter)

Updated

a year ago
Whiteboard: [photon-performance][qf]
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1361140
Whiteboard: [photon-performance][qf]
You need to log in before you can comment on or make changes to this bug.