Folder Pane Toolbar Label has been slightly moved to right

RESOLVED FIXED in Thunderbird 55.0

Status

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: ovari123, Assigned: Paenglab)

Tracking

54 Branch
Thunderbird 55.0
All
Linux

Thunderbird Tracking Flags

(thunderbird_esr5254+ fixed, thunderbird54 fixed, thunderbird55 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170421105455

Steps to reproduce:

Menu Bar → View → Toolbars → Folder Pane Toolbar (enabled)


Actual results:

Image link below shows the “Folder Pane Toolbar” with “All Folders” selected; however, it is also been slightly moved to the right on Linux. On Windows it is shown correctly.

https://bugzilla.mozilla.org/show_bug.cgi?id=1360463#c14
https://bugzilla.mozilla.org/attachment.cgi?id=8863366

Updated

2 years ago
Component: Untriaged → Folder and Message Lists

Comment 1

2 years ago
Related to bug 1360463?
Flags: needinfo?(richard.marti)
(Assignee)

Comment 2

2 years ago
No, unfortunately to bug 1354263. I'm on a patch.
Flags: needinfo?(richard.marti)
(Assignee)

Comment 3

2 years ago
Created attachment 8863767 [details] [diff] [review]
Bug1361157.patch

I move the rule to folderMenus.css because we have only icons in the menulist where we use them to show folders.

Or are other menulists with icon in it in our tree?
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8863767 - Flags: review?(acelists)

Comment 4

2 years ago
Any screenshots what this is intended to do please?
(Assignee)

Comment 5

2 years ago
Created attachment 8863880 [details]
32px-menulist.png

If the user sets the GTK icon size to 32px it would look like this without the rule.

Comment 6

2 years ago
And with the patch? I can't set the icon sizes here.
(Assignee)

Comment 7

2 years ago
Created attachment 8863888 [details]
withPatch.png

With patch as it looks too without patch and normal 16px icons.

Comment 8

2 years ago
Comment on attachment 8863767 [details] [diff] [review]
Bug1361157.patch

Review of attachment 8863767 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8863767 - Flags: review?(acelists) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
OS: Unspecified → Linux
Hardware: Unspecified → All

Comment 9

2 years ago
https://hg.mozilla.org/comm-central/rev/85e4fa4ed2d3c37f65cd820836d781b503dfd560
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
(Assignee)

Comment 10

2 years ago
Comment on attachment 8863767 [details] [diff] [review]
Bug1361157.patch

[Approval Request Comment]
Regression caused by (bug #): 1354263 which is in ESR52
User impact if declined: shifted text in menulists without icons
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8863767 - Flags: approval-comm-esr52?
Attachment #8863767 - Flags: approval-comm-beta?

Updated

2 years ago
Attachment #8863767 - Flags: approval-comm-beta? → approval-comm-beta+

Comment 11

2 years ago
Beta (TB 54):
https://hg.mozilla.org/releases/comm-beta/rev/a3dc003cd9e3c592f6537e5afb6f5613a1cfe12e
status-thunderbird54: --- → fixed
status-thunderbird55: --- → fixed
status-thunderbird_esr52: --- → affected

Updated

a year ago
Attachment #8863767 - Flags: approval-comm-esr52? → approval-comm-esr52+

Comment 12

a year ago
TB 52 ESR:
https://hg.mozilla.org/releases/comm-esr52/rev/4db68dce7ab6b48509638c34c821f33727ffce3d
status-thunderbird_esr52: affected → fixed
tracking-thunderbird_esr52: --- → 54+
You need to log in before you can comment on or make changes to this bug.