/home/product/Firefox lists too many versions

VERIFIED FIXED

Status

Socorro
Webapp
VERIFIED FIXED
7 months ago
5 months ago

People

(Reporter: mossop, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 months ago
This page is listing four different versions of Firefox however since dropping the aurora channel the 54a2 version should not be listed.
(Assignee)

Comment 1

7 months ago
What is the "Current versions page"?

If you refer to the drop-down in the nav, that's generated by us scraping https://archive.mozilla.org and then for every new version we store it in the database with a default "sunset date" of NOW + 36 weeks.

Note-to-self: https://github.com/mozilla/socorro/blob/master/socorro/external/postgresql/raw_sql/procs/sunset_date.sql#L14
(Reporter)

Comment 2

7 months ago
Sorry I forgot the link: https://crash-stats.mozilla.com/home/product/Firefox
(Assignee)

Comment 3

7 months ago
Ah! I think I understand now. 

What versions are listed on the home page comes from us scraping: https://product-details.mozilla.org/1.0/firefox_versions.json
Here's the relevant code: https://github.com/mozilla/socorro/blob/55beaf1281e7b522e0526b2aa2bf74d15f6c1263/socorro/cron/jobs/featured_versions_automatic.py#L101-L110

Given that Aurora is going away we should STOP looking for `FIREFOX_AURORA` in that JSON. Instead we should just have FIREFOX_NIGHTLY, LATEST_FIREFOX_VERSION (aka release) and LATEST_FIREFOX_DEVEL_VERSION (aka beta).

So we should certainly stop figuring out what the featured Aurora version is. Can someone tell me the exact date when this goes into effect? 

I'll prep the code change and once that lands we can manually change the 54a2 version from being featured.
Assignee: nobody → peterbe
(Assignee)

Comment 4

7 months ago
Sylvestre,
Pardon me for not keeping up with the massive Project Dawn email thread. 

When exactly should we stop feature Aurora (aka. 54) on the Crash-stats home page?
I'm pretty confident I know what/how to do that, just need a little guidance on the when.
Flags: needinfo?(sledru)
(Assignee)

Comment 5

7 months ago
Created attachment 8863844 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3747
We should remove it when we merged the aurora population on beta (in a few weeks).
Thanks for asking!
Blocks: 1353899
Flags: needinfo?(sledru)
Duplicate of this bug: 1376054
(In reply to Sylvestre Ledru [:sylvestre] from comment #6)
> We should remove it when we merged the aurora population on beta (in a few
> weeks).

The aurora-channel delivers now betas...
QA Contact: Tobias.Besemer
Summary: Current versions page lists too many versions → /home/product/Firefox lists too many versions
yes, this is indeed time to remove it! thanks

Comment 10

5 months ago
Commit pushed to master at https://github.com/mozilla-services/socorro

https://github.com/mozilla-services/socorro/commit/3fbad02980f4074b2fbbf9bd5f67e16374d1c543
bug 1361179 - stop making Aurora a featured version (#3747)
(Assignee)

Comment 11

5 months ago
Created attachment 8881802 [details]
Screen Shot 2017-06-28 at 9.53.25 AM.png

Verified on stage. 

Will close once this goes to prod. 
NOTE! Will need a admin node upgrade.
WFM now!
(Assignee)

Comment 13

5 months ago
Yay!
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.