Don't install pending updates when there is a running instance of Firefox

RESOLVED DUPLICATE of bug 1112937

Status

()

RESOLVED DUPLICATE of bug 1112937
2 years ago
a year ago

People

(Reporter: mayhemer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
(Win 10)

This will probably mostly effect only developers and users on hi-rate update channels (specially Nightly).  

I use Nightly as my daily browser.  But I also sometimes run the same installation with a different profile (-no-remote).  When there is a pending update downloaded by the already running instance (offering a restart) and I start a second instance with -no-remote, the update is applied!

This definitely at least destroys icon pinning on the Windows task bar, since when I quit the regular profile and start it again, it will get it's own icon on the task bar that cannot be pinned.  I can only unpin the original icon and then only chance to start the browser is to run firefox.exe manually from the installation folder and then pin the icon again.

The updater really should detect a running instance.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112937
(Reporter)

Comment 2

2 years ago
:D
You need to log in before you can comment on or make changes to this bug.