Closed Bug 1361437 Opened 5 years ago Closed 5 years ago

Running Weave.js at app-startup is really expensive and slows down browser start-up

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1358648

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qf])

Here's a profile:

https://perfht.ml/2pCdHrn

I captured this using MOZ_PROFILER_STARTUP on Nightly using the Photon benchmark hardware. In this profile, we're spending 42ms running Weave.js, and most of that seems to be loading the util.js script here: http://searchfox.org/mozilla-central/rev/ae8c2e2354db652950fe0ec16983360c21857f2a/services/sync/Weave.js#13

Is it necessary to bring all of that util.js stuff in right away? How much of it can be imported lazily?
Hey markh, out of curiosity, do you know how much of util.js absolutely needs to be brought in before the first browser window paint?
Flags: needinfo?(markh)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358648
Whiteboard: [qf][photon-performance] → [qf]
(In reply to Mike Conley (:mconley) from comment #1)
> Hey markh, out of curiosity, do you know how much of util.js absolutely
> needs to be brought in before the first browser window paint?

Even though we are now tracking this in bug 1358648, FWIW, we should certainly be able to avoid pulling that file in before first paint.
Flags: needinfo?(markh)
You need to log in before you can comment on or make changes to this bug.