Bookmarks print over right border of personal toolbar (Classic theme, seemingly Modern, too)

VERIFIED DUPLICATE of bug 122208

Status

SeaMonkey
Bookmarks & History
--
trivial
VERIFIED DUPLICATE of bug 122208
16 years ago
13 years ago

People

(Reporter: Andreas Kunz, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

If the personal toolbar has not enough space for all its bookmarks, the last
(rightmost) one is cut off - which is ok as far as I'm concerned.
But in Classic theme the cutoff appears to happen 2 pixel too far to the right,
so the bookmark seems to be printed partly outside of the toolbar area.

Reproducible: Always
Steps to Reproduce:
1. start mozilla
2. be sure to have more bookmarks/folders in the personal toolbar than there is
space for (e.g. by making the mozilla window smaller if necessary)
3. watch closely where the rightmost entry in the personal toolbar is cut off
because the toolbar hasn't enough space for it.

Actual Results:  The rightmost entry is printed 2 pixel over the right border of
the toolbar, which looks a bit ugly.

Expected Results:  This entry should have been cut off at least 2 pixel earlier
(more to the left), so it fits in the toolbar area.

While I report this using 0.9.9 on Win95 I am quite sure that it also happens on
another computer running Win 2000.
Not sure about other Platforms/OS, though. Therefore I report it only for
PC/Win95. Feel free to change that...

When watching the window being redrawn (quite possible on a Pentium 200...) the
bookmark is printed first and looks so far ok, because there is enough distance
to the edge of the Mozilla window.
But later the shaded borders of the window areas are drawn - and the one of the
personal toolbar is drawn under the right side of the bookmark, so the bookmark
suddenly appears to be printed too far to the right.

I think I've been seeing this for a long time already, but didn't file a bug
because it seemed so obvious to me. Now I still didn't find a bug about this
problem, so I finally filed one.

This bug has nothing to do with 118550, 66919 and 118596, which are about
handling toolbar overflows and problems arising in that case, but is purely
cosmetic and only affects classic skin.

Should not be too hard to fix, I suppose, for one who knows about themes
probably quicker than filing the bug...
(Reporter)

Comment 1

16 years ago
Created attachment 78181 [details]
Screenshot with two examples, each with magnification.

This screenshot shows two examples, where a bookmark respectively a bookmark
icon are printed over the right personal toolbar border.
Each example also magnified by 300 %

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 120702 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
oops! not a dup at all
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

16 years ago
Created attachment 79057 [details]
Bookmark folders printed over border of toolbar-holder and even 1px further.

One more screenshot that clearly shows how bookmarks toolbar elements are
visibly printed over the right border of the personal toolbar.

I modified toolbar.css and set border-right to 5px because I didn't know, where
else to look for the problem:

.toolbar-holder {
[...]
  border-right: 5px solid ThreeDShadow;
[...]
} 

This causes all toolbars to have a very wide dark right border (at least
something like that).
And on the screenshot you can see that bookmark icons (written bookmark names
as well) and the border, that bookmark folders show, when hovered over, are
both printed not only on that border, but even one pixel further to the right.

I expected that this toolbar-holder would actually hold the toolbar items, but
it does not seem to. But I can't find the place, where things go wrong, yet. Is
there any XUL guy able to help me on this?
(Reporter)

Comment 5

16 years ago
Not a dupe in fact, but maybe still related to Bug 120702 - at least the
behaviour there looks much like here.
(Reporter)

Updated

16 years ago
Keywords: polish
Summary: Bookmarks print over right border of personal toolbar (Classic theme) → Bookmarks print over right border of personal toolbar (Classic theme, seemingly Modern, too)
(Reporter)

Comment 6

16 years ago
Created attachment 79242 [details]
Modern theme seems also affected

Just discovered that Bug also seems to appear in Modern theme, only less
visible because of the colors used and the fact that the toolbar ends one pixel
farther to the right in Modern (-> only 1px overlap).

This might speak against relation to Bug 120702 because that one appears only
with Classic theme. On the other hand, the sidebar might have been constructed
differently in Modern, avoiding the component(s) that cause the error...

Adding 'polish' keyword, modifying summary to reflect this recent discovery.
(Reporter)

Comment 7

16 years ago
Created attachment 79984 [details]
Screenshot: bug also on Linux (1.0.0 RC1)

Screenshot shows same behaviour on Linux.
(Reporter)

Comment 8

16 years ago
Finally tested it on my Linux box (with 1.0.0 RC1). Looks the same there - as
expected. Quite sure now that it is a UI/theme problem, not a platform one.
=> platforms/OS = all
OS: Windows 95 → All
Hardware: PC → All
with 640x480 on a 19" screen I see it with knowing it's there...
(Build ID 2002051907/Linux)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
this isn't a theme bug, it's a xul bug. it also happens in the sidebar.
Assignee: shliang → ben
Component: Themes → Bookmarks
QA Contact: pmac → claudius

Comment 11

15 years ago

*** This bug has been marked as a duplicate of 122208 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.