Closed Bug 136169 Opened 18 years ago Closed 18 years ago

imported or linked style sheets are not processed

Categories

(Core :: CSS Parsing and Computation, defect)

PowerPC
Mac System 9.x
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: lbutler, Assigned: dbaron)

Details

<LINK rel="stylesheet" type="text/css" href="bi.css" title="Default SS">

Including a imported style sheet, either through <LINK ...> or @import results in no style information being processed.  If the style sheet is actually part of the file and not read externally then the styles are processed correctly.

please see <http://www.butlerinstitute.com> and <http://www.butlerinstitute.com/cgi-local/b4.pl?cn=0&fn=class.csv&ti=Class%20List> for examples (same style sheet, first link does not work, second link does.

passed W3 validator tests and displays correctly in OS X IE 5 and OS X Opera and Win Opera and mostly correct in OS X Omniweb beta2 and windows IE 6.
The problem is that your server is serving the stylesheet as "text/plain" rather
than "text/css".
Marking invalid.  (See previous comment.)  Note that we only do the mime type
check in standards mode:  see http://mozilla.org/docs/web-developer/quirks/ .
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
The server seems to have been fixed -- it is being sent as text/css now, and the
page renders with style.

VERIFIED WORKSFORME.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.