Closed Bug 1361697 Opened 3 years ago Closed 3 years ago

Use info-pages.css for about:license

Categories

(Toolkit :: Themes, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla55
Iteration:
55.6 - May 29
Tracking Status
firefox55 --- fixed
firefox57 --- verified

People

(Reporter: dao, Assigned: tiago, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug, Whiteboard: [reserve-photon-visual][p4][good first bug][lang=css])

Attachments

(1 file)

Mockup: https://mozilla.invisionapp.com/share/ZKBC94BPQ#/screens/229803192

Required changes:

- stop setting border, background, color and custom padding on <body>
- make <h1> use font-weight: lighter; and increase font-size to about 2.4em
- increase default line-height
- remove list-style: square; from unordered lists
Keywords: good-first-bug
Summary: Update about.css for Photon design → Update toolkit/themes/shared/about.css for Photon design
Whiteboard: [photon-visual][p1] → [photon-visual][p1][good first bug][lang=css]
Flags: qe-verify?
Priority: -- → P2
Assignee: nobody → prathikshaprasadsuman
Status: NEW → ASSIGNED
Priority: P2 → P1
I think it would be better to get rid of about.css altogether and use toolkit/themes/shared/in-content/info-pages.css instead.

Many pages are already using it (about:neterror/certerror/blocked/privatebrowsing/sessionrestore/welcomeback/tabcrashed) and the layout of about:license/about/credits is supposed to be pretty similar.
Flags: qe-verify? → qe-verify+
QA Contact: brindusa.tot
Whiteboard: [photon-visual][p1][good first bug][lang=css] → [reserve-photon-visual][p2][good first bug][lang=css]
Whiteboard: [reserve-photon-visual][p2][good first bug][lang=css] → [reserve-photon-visual][p4][good first bug][lang=css]
Prathiksha, are you working on this?
Mentor: dao+bmo
Flags: needinfo?(prathikshaprasadsuman)
No, I'm not. I am a little busy at the moment. So sorry. I'll unassign myself so someone else can take it up. :)
Flags: needinfo?(prathikshaprasadsuman)
Assignee: prathikshaprasadsuman → nobody
Status: ASSIGNED → NEW
Priority: P1 → P3
Hi, could I work on this bug(as my first bug)?
(In reply to Pooja Arora from comment #4)
> Hi, could I work on this bug(as my first bug)?

Sure. Do you have the source code? Have you built Firefox yet?
Hi!

I just submitted a patch for this and I also just see that Pooja wanted to take it.

The patch I submitted is a first attempt at it and it's missing things to really look like the uploaded mockup.

If what I did is fine, I'm happy to let Pooja complete it.

If not, he can ignore my patch :)
Flags: needinfo?(dao+bmo)
Assignee: nobody → tiago.paez11
Status: NEW → ASSIGNED
Priority: P3 → P1
(In reply to Dão Gottwald [::dao] from comment #5)
> (In reply to Pooja Arora from comment #4)
> > Hi, could I work on this bug(as my first bug)?
> 
> Sure. Do you have the source code? Have you built Firefox yet?

I am completely new, yet to get and build the source code.
(In reply to Pooja Arora from comment #8)
> (In reply to Dão Gottwald [::dao] from comment #5)
> > (In reply to Pooja Arora from comment #4)
> > > Hi, could I work on this bug(as my first bug)?
> > 
> > Sure. Do you have the source code? Have you built Firefox yet?
> 
> I am completely new, yet to get and build the source code.

I've filed bug 1367326 on updating about.css since Santiago chose to use info-pages.css for about:license. Please comment over there if you'd like to take that bug.
Flags: needinfo?(dao+bmo)
Summary: Update toolkit/themes/shared/about.css for Photon design → Use info-pages.css for about:license
Comment on attachment 8870578 [details]
Bug 1361697 - Use toolkit/themes/shared/in-content/info-pages.css for about:license.

https://reviewboard.mozilla.org/r/142038/#review145858

::: toolkit/themes/shared/in-content/info-pages.inc.css:56
(Diff revision 1)
>  .title-text {
>    font-size: inherit;
>    padding-bottom: 0.4em;
>  }
>  
> +.path {

How about we replace <span class="path"> with <code>?
Attachment #8870578 - Flags: review?(dao+bmo) → review+
(In reply to Dão Gottwald [::dao] from comment #10)
> Comment on attachment 8870578 [details]
> Bug 1361697 - Use toolkit/themes/shared/in-content/info-pages.css for
> about:license.
> 
> https://reviewboard.mozilla.org/r/142038/#review145858
> 
> ::: toolkit/themes/shared/in-content/info-pages.inc.css:56
> (Diff revision 1)
> >  .title-text {
> >    font-size: inherit;
> >    padding-bottom: 0.4em;
> >  }
> >  
> > +.path {
> 
> How about we replace <span class="path"> with <code>?

Thanks..I have updated there if I could work on the bug https://bugzilla.mozilla.org/show_bug.cgi?id=1367326
Blocks: 1361689
Thanks Santiago. I'll try landing your patch now.
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c992c7e903ce
Use toolkit/themes/shared/in-content/info-pages.css for about:license. r=dao
https://hg.mozilla.org/mozilla-central/rev/c992c7e903ce
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Iteration: --- → 55.6 - May 29
Tested on Windows 10 x64, Ubuntu 16.04 x64, Mac OS X 10.12 with FF Nightly 57.0a1(2017-08-08) and I can confirm the fix. about:license page use info-pages.css
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.