CSS > list-style-type incorrectly states that <li> is the only element with display: list-item by default

RESOLVED WORKSFORME

Status

P5
normal
RESOLVED WORKSFORME
2 years ago
9 months ago

People

(Reporter: clone53421, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

In the doc for list-style-type, the first paragraph states:

"Because the <li> element is the only property that defaults to display:list-item, this property is usually applied to an <li> element, but it may be applied to any element whose display value is list-item."

This is incorrect; <li> is no longer the only element which defaults to display:list-item. As stated on https://developer.mozilla.org/en-US/docs/Web/HTML/Element/summary:

"The default style for <summary> is display:list-item per HTML standard."

Comment 1

9 months ago
This is fixed.
(Reporter)

Updated

9 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

9 months ago
(In reply to radick334 from comment #1)
> This is fixed.

It is indeed. I can't figure out how to mark this as resolved fixed, nor does it seem that I can delete it, so I'm just changing the status to RESOLVED WORKSFORME.
You need to log in before you can comment on or make changes to this bug.