If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

uploading images on twitter is broken in FF55

RESOLVED DUPLICATE of bug 1361443

Status

()

Core
DOM
P1
normal
RESOLVED DUPLICATE of bug 1361443
5 months ago
5 months ago

People

(Reporter: bkelly, Assigned: baku)

Tracking

({regression})

unspecified
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(platform-rel ?, firefox54 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
[Tracking Requested - why for this release]:

STR:

1) Login in to twitter.com
2) Attempt to send a tweet with an image

On FF55 I get a message that says "Uploading media failed! Please try again later."  On FF53 and FF54 it works.
(Reporter)

Comment 1

5 months ago
Created attachment 8864180 [details]
Screenshot 2017-05-03 11.21.23.png

Comment 2

5 months ago
https://hg.mozilla.org/mozilla-central/rev/82c2d17e74ef9cdf38a5d5ac4eb3ae846ec30ba4
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0 ID:20170503030212

I can reproduce the problem on latest Nightly.



Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c35f0ad34397990adec0612015eb1a2a566434da&tochange=cf6065f64f9a8aef42144e7938c9c1aec92d8677


regressed by:
cf6065f64f9a	Andrea Marchesini — Bug 1359172 - RemoteInputStream must create a correct inputStream when used and sliced in a separate process, r=smaug
2629873b5fdc	Andrea Marchesini — Bug 1358115 - Use IPCBlob in DataTransfer, r=smaug
049673ad3893	Andrea Marchesini — Bug 1358113 - Use IPCBlob in File.createFromNsIFile/createFromFileName, r=smaug
2ef7ae7a605f	Andrea Marchesini — Bug 1358114 - Use IPCBlob in BlobURL, r=smaug
7d7576b29e2b	Andrea Marchesini — Bug 1358111 - Use IPCBlob in Entries API - part 2 - Entries API, r=smaug
b3cc0e03d9b7	Andrea Marchesini — Bug 1358111 - Use IPCBlob in Entries API - part 1 - GetFilesHelper, r=smaug
4de83aa3b817	Andrea Marchesini — Bug 1358109 - Use IPCBlob in PFilePicker, r=smaug




And I confirmed that Bug 1361315 and 1360887 does not fix the problem.
status-firefox54: --- → unaffected
status-firefox55: --- → affected
Component: Untriaged → DOM
Flags: needinfo?(amarchesini)
Keywords: regressionwindow-wanted

Comment 3

5 months ago
Regression range (using drag and drop):
Via local build,
Last Good: 049673ad3893
First Bad: 2629873b5fdc

Regressed by: 2629873b5fdc	Andrea Marchesini — Bug 1358115 - Use IPCBlob in DataTransfer, r=smaug


Regression range (using Filepicker):
Via local build,
Last Good: c35f0ad34397
First Bad: 4de83aa3b817

4de83aa3b817	Andrea Marchesini — Bug 1358109 - Use IPCBlob in PFilePicker, r=smaug
Blocks: 1358115, 1358109
Assignee: nobody → amarchesini
Priority: -- → P1
(Reporter)

Updated

5 months ago
Duplicate of this bug: 1361919
(Assignee)

Comment 5

5 months ago
This bug is a duplicate of bug 1361443. But I want to keep it open in case more duplicates are filed.
Flags: needinfo?(amarchesini)
(Assignee)

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1361443
Adjusting tracking flags based on the dupe status.
status-firefox55: affected → wontfix
tracking-firefox55: ? → -
(In reply to Marcia Knous [:marcia - use ni] from comment #7)
> Adjusting tracking flags based on the dupe status.

Really? Bug 1361443 has no tracking flags. The fix is landed on inbound and it will be merged very soon.
Flags: needinfo?(mozillamarcia.knous)
(In reply to Masatoshi Kimura [:emk] from comment #8)
> (In reply to Marcia Knous [:marcia - use ni] from comment #7)
> > Adjusting tracking flags based on the dupe status.
> 
> Really? Bug 1361443 has no tracking flags. The fix is landed on inbound and
> it will be merged very soon.

I was just about to do it, Julien beat me to it. We need to clear the flags for dupes so they don't show up on the health dashboard.
Flags: needinfo?(mozillamarcia.knous)
(In reply to Marcia Knous [:marcia - use ni] from comment #9)
> I was just about to do it, Julien beat me to it. We need to clear the flags
> for dupes so they don't show up on the health dashboard.

Then please clear the status-firefox55 instead of marking it as wontfix. Wontfix is simply wrong.
Flags: needinfo?(mozillamarcia.knous)
status-firefox55: wontfix → ---
tracking-firefox55: - → ---
Flags: needinfo?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.