Cookies not being sent to server

RESOLVED WORKSFORME

Status

()

Core
Networking: Cookies
RESOLVED WORKSFORME
16 years ago
9 months ago

People

(Reporter: Endre Stolsvik, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have this Tomcat (Java Servlets) system set up, and was experiencing problems
with the session tracking. It seemed like Mozilla didn't send the cookies to
tomcat, making tomcat make a new session for every request.

The URL was this: http://localhost:10000/server/Monitor

In the Cookie Manager, I can see the cookie (JSESSIONID) with the correct value
and all, but I still get a new cookie for each request. This is also reflected
in the Cookie Manager.

In the Privacy & Security section, while bughunting I checked "Ask med before
storing a cookie". But at the same time saw that I had checked "Enable cookies
for the originating web site only". I instead checked "Enable all cookies". This
turned out to be the trick, all of a sudden everything works.

This is build 2002040706.. It has been like this since at least 0.9.9.
This can be a dup of bug 134203, which is now fixed. Endre, can you try a newer
build, and check it? If it is ok then, please mark this as a duplicate.
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

9 months ago
Pushed by dd.mozilla@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7ede4e827120
Keep list of weakPtrs instead of streamIds of streams started during 0rtt. r=mcmanus
You need to log in before you can comment on or make changes to this bug.