Intermittent testSessionOOMSave | application crashed [@ __libc_android_abort]

RESOLVED DUPLICATE of bug 1365330

Status

()

Firefox for Android
Testing
P3
critical
RESOLVED DUPLICATE of bug 1365330
a year ago
10 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

https://public-artifacts.taskcluster.net/Zg2dLSQeTB2HZVattRfd2Q/0/public/test_info//logcat-emulator-5554.log

05-10 07:22:01.661  2751  2764 I Robocop : {"message":"","time":1494426121660,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"Waiting for Toolbar to enter editing mode.","action":"test_status","pid":null}
05-10 07:22:03.172  2751  2764 I Robocop : {"message":"","time":1494426123174,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"Waiting for UrlEditText to be input method target.","action":"test_status","pid":null}
05-10 07:22:03.182  2751  2764 I Robocop : {"message":"http:\/\/mochi.test:8888\/tests\/robocop\/robocop_dynamic.sjs?id=page2 should not equal null","time":1494426123179,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"url is not null","action":"test_status","pid":null}
05-10 07:22:05.212  2751  2764 I Robocop : {"message":"","time":1494426125212,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"The toolbar is in the editing state","action":"test_status","pid":null}
05-10 07:22:06.232  2751  2764 I Robocop : {"message":"","time":1494426126235,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"The UrlEditText is the input method target","action":"test_status","pid":null}
05-10 07:22:07.042   277   280 D dalvikvm: GC_CONCURRENT freed 1531K, 45% free 5645K/10180K, paused 6ms+11ms, total 182ms
05-10 07:22:08.301  2751  2751 D dalvikvm: GC_FOR_ALLOC freed 648K, 17% free 9345K/11216K, paused 86ms, total 95ms
05-10 07:22:08.731  2751  2841 F libc    : @@@ ABORTING: invalid address or address of corrupt block 0x2a554d58 passed to dlfree


https://public-artifacts.taskcluster.net/FAwE0KCDSZCChO-JSnG51Q/0/public/test_info//logcat-emulator-5554.log

05-03 14:01:57.608  2581  2594 I Robocop : {"message":"","time":1493845317605,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"Waiting for Toolbar to enter editing mode.","action":"test_status","pid":null}
05-03 14:01:59.118  2581  2594 I Robocop : {"message":"","time":1493845319120,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"Waiting for UrlEditText to be input method target.","action":"test_status","pid":null}
05-03 14:01:59.128  2581  2594 I Robocop : {"message":"http:\/\/mochi.test:8888\/tests\/robocop\/robocop_dynamic.sjs?id=page2 should not equal null","time":1493845319125,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"url is not null","action":"test_status","pid":null}
05-03 14:02:01.158  2581  2594 I Robocop : {"message":"","time":1493845321154,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"The toolbar is in the editing state","action":"test_status","pid":null}
05-03 14:02:02.168  2581  2594 I Robocop : {"message":"","time":1493845322170,"source":"robocop","status":"PASS","test":"testSessionOOMSave","thread":null,"subtest":"The UrlEditText is the input method target","action":"test_status","pid":null}
05-03 14:02:04.478   277   279 D dalvikvm: GC_CONCURRENT freed 1526K, 45% free 5622K/10100K, paused 4ms+59ms, total 232ms
05-03 14:02:04.757  2581  2686 F libc    : @@@ ABORTING: invalid address or address of corrupt block 0x2a4745b8 passed to dlfree
This test was re-enabled in bug 1348086, a couple of months ago.

:JanH -- Any ideas?
Blocks: 1348086
Flags: needinfo?(jh+bugzilla)
Priority: -- → P3
Nope - if you look at the crash stack in the robocop log, you can see that these are somehow SSL related crashes, but that's as far as my abilities go.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jh+bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1365330

Comment 4

a year ago
1 failures in 814 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-06-12&endday=2017-06-18&tree=all

Comment 5

a year ago
1 failures in 892 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-06-19&endday=2017-06-25&tree=all

Comment 6

a year ago
1 failures in 718 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-api-15-gradle: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-06-26&endday=2017-07-02&tree=all

Comment 7

a year ago
1 failures in 720 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-api-15-gradle: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-07-10&endday=2017-07-16&tree=all

Comment 8

a year ago
1 failures in 822 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 1

Platform breakdown:
* android-api-15-gradle: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-07-17&endday=2017-07-23&tree=all

Comment 9

a year ago
1 failures in 888 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-07-31&endday=2017-08-06&tree=all

Comment 10

11 months ago
1 failures in 901 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-08-07&endday=2017-08-13&tree=all

Comment 11

11 months ago
2 failures in 939 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* android-api-16-gradle: 1
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-08-28&endday=2017-09-03&tree=all

Comment 12

11 months ago
1 failures in 924 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-09-04&endday=2017-09-10&tree=all

Comment 13

10 months ago
1 failures in 943 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1361924&startday=2017-09-18&endday=2017-09-24&tree=all
You need to log in before you can comment on or make changes to this bug.