Closed Bug 1362246 Opened 3 years ago Closed 2 years ago

Add SourceSurface::ToLuminance() to avoid calling GetDataSurface() during drawing

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1359527

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

Details

Attachments

(1 file)

A bit of a hack, but oh well.
Blocks: 1362245
I think it's probably better to just do this directly on the DrawTarget. I'm planning on adding DrawTarget::IntoLumaSource(). Any objections to this Bas?
Flags: needinfo?(bas)
Nope.
Flags: needinfo?(bas)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #2)
> I think it's probably better to just do this directly on the DrawTarget. I'm
> planning on adding DrawTarget::IntoLumaSource(). Any objections to this Bas?

I have something like this in bug 1359527, has one stylo reftest failure though.
See Also: → 1359527
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359527
You need to log in before you can comment on or make changes to this bug.