Closed Bug 1362305 Opened 5 years ago Closed 4 years ago

Tab bar partly hidden [Tab Groups]

Categories

(WebExtensions :: General, defect)

55 Branch
x86
macOS
defect
Not set
major

Tracking

(firefox53 unaffected, firefox54 unaffected, firefox55 wontfix)

RESOLVED WONTFIX
Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- wontfix

People

(Reporter: alberts, Unassigned)

References

Details

(Keywords: regression)

In Nightly after 2017-05-02 is the tab bar broken / partly hidden when "Tab Groups" is enabled.

I have also filed an issue (with screenshot) over at the add-ons Github repo: https://github.com/Quicksaver/Tab-Groups/issues/541
The developer noted in the add-on's "About" page that the update from January 27, 2017 was the last update[1]. Therefore it seems little likely to me that this will be fixed for 55/56 from his side.
I was hoping that someone could have a look at the regression range and see if something can be (un-)done on Firefox's site.


[1] http://fasezero.com/lastnotice.html
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:55.0) Gecko/20100101 Firefox/55.0
Firefox: 55.0a1, Build ID: 20170508030204

I have managed to reproduce this issue only on Mac Os on latest Nightly (55.0a1) build. I have performed a regression range and here are the results:

Last good revision: af0598e94338f6fb803a3dec0f56728ce179f954
First bad revision: cf470e6222f971b5cb4551ff627b49152a326c22
Pushlog: https://goo.gl/xw1tJR

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1352364

Johann, can you please take a look at this?
Blocks: 1352364
Flags: needinfo?(jhofmann)
Component: Extension Compatibility → Add-ons
Product: Firefox → Tech Evangelism
Version: 55 Branch → Firefox 55
Thanks for moving, dao. This is not something we will undo on Firefox side. We consolidated our toolbar styling to be the same across all three platforms, so this shouldn't be hard to fix on add-on side by changing their code to use the CSS they use for Windows.
Flags: needinfo?(jhofmann)
There is a workaround here while the add-on is still working:
https://github.com/Quicksaver/Tab-Groups/issues/541#issuecomment-309524788

The add-on developer announced already that he will not update his code anymore; closing this as wontfix
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
Version: Firefox 55 → 55 Branch
You need to log in before you can comment on or make changes to this bug.