Closed Bug 1362328 Opened 5 years ago Closed 4 years ago

Tabs not restored after second crash

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox53 affected, firefox54 affected, firefox55 affected)

RESOLVED INVALID
Tracking Status
firefox53 --- affected
firefox54 --- affected
firefox55 --- affected

People

(Reporter: oana.horvath, Unassigned)

References

Details

Attachments

(1 file)

452.07 KB, text/plain
Details
Build: Nightly 55.0a1 (2017-05-05);
Device: 
Asus ZenPad 8.0 Z380KL (Android 6.0.1);

Steps to reproduce:
1. Go to Settings>Advanced>Restore tabs and set "Don't restore tabs".
2. Open a few tabs.
3. Install the Crash me addon and launch it (or trigger any other crash) twice.

Expected result:
The tabs are restored when there's a crash, even with "Don't restore tabs" on.

Actual result:
After the first crash, the tabs are restored.
On second crash, the tabs are not restored. 
The Recently closed tab is opened, but not all tabs that were closed are shown every time.
(In reply to Oana Horvath from comment #0)
> Actual result:
> After the first crash, the tabs are restored.
> On second crash, the tabs are not restored. 

That's expected in order to break out of possible startup crash loops caused by the currently selected tab. There's one possible improvement for the current code, though: At the moment, the crash counter is reset only if we manage a background-foreground cycle without crashing. What we probably should (additionally/instead?) do is reset it a minute or two after startup if we didn't crash by then. If we absolutely wanted, we could also tweak the number of successive crashes allowed before we disable automatic session restoring.

> The Recently closed tab is opened, but not all tabs that were closed are
> shown every time.

That would require some logs (with "browser.sessionstore.debug_logging" enabled) to further diagnose.
Attached file log3.txt
Attached is the log file, from Nightly 55 5/5/2017, where I could reproduce the second issue after a few tries.
(In reply to Oana Horvath from comment #0)
> The Recently closed tab is opened, but not all tabs that were closed are
> shown every time.

How many tabs did you have open before the crash and how many were missing afterwards? Also, were those missing tabs by any chance the most recently opened ones?

In the log I don't see anything odd - tabs are written to disk at most every 10 s, so it's expected that the last few seconds of browsing (in this case opening a second tab) can get lost after a crash.
Flags: needinfo?(oana.horvath)
You're right, it takes about 10s for the tabs to be saved and restored after a crash. Wasn't aware of that, thank you.
I'll mark this bug as invalid then.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(oana.horvath)
Resolution: --- → INVALID
See Also: → 1363321
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.