Status

VERIFIED INVALID
2 years ago
a year ago

People

(Reporter: zosrothko, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

2 years ago
Created attachment 8864788 [details]
The debug log of the FirefoxTest execution

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

1/Run the FirefoxTest.java attached


Actual results:

An invalid 404 error was returned. See FirefoxTest-404.txt and the source code of the html page adressed.


Expected results:

clicked
clicked
(Reporter)

Comment 1

2 years ago
Created attachment 8864789 [details]
The source of FirefoxTest.java
(Reporter)

Comment 2

2 years ago
Created attachment 8864790 [details]
The rendered html page http://localhost:8080/nicedemo
(Reporter)

Comment 3

2 years ago
There is an additional info about this issue. When running the Firefoxtest.java under Eclipse with the debugger with a breakpoint at line 61, the xpath element is found as displayed in the FirefoxTest-404-with-debug.txt attachment.
(Reporter)

Comment 4

2 years ago
Created attachment 8864795 [details]
Log of the Firefoxtest with a breakpoint line 61
(Reporter)

Comment 5

2 years ago
geckodriver 0.16.1
FF 53.0 (32 bits)
Selenium 3.4.0
(Reporter)

Comment 6

2 years ago
Expected Results

[[FirefoxDriver: firefox on ANY (cfce20a5-24f8-4827-bf7b-b14ac4c43db2)] -> xpath: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4]
clicked
[[FirefoxDriver: firefox on ANY (cfce20a5-24f8-4827-bf7b-b14ac4c43db2)] -> xpath: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[1]/h4]
clicked
Attachment #8864789 - Attachment mime type: text/x-java → text/plain
Both tests work fine for me locally when using Marionette directly. So which version of the Java Selenium bindings do you have? Make sure it's the latest. Also please test with a latest Firefox Nightly, and provide a new trace log if it still doesn't work.
Flags: needinfo?(zosrothko)
(Reporter)

Comment 8

2 years ago
These are the version for each components

geckodriver 0.16.1
FF 53.0 (32 bits)
Selenium 3.4.0

Could you have a look at this issue? https://github.com/mozilla/geckodriver/issues/659#issuecomment-295724264
Flags: needinfo?(zosrothko)
The issue is different and I would like to not mix topics. Please do the second half of my requested items of the last comment. Thanks.
(Reporter)

Comment 10

a year ago
Tested with FF Nightly 55.0a1 (2017-05-14) (32 bits). Same result as shown in the attachment Firefox_Nightly_55.0a1 (2017-05-14) (32 bits).txt. Same behavior also when run under Eclipse's debugger.
(Reporter)

Comment 11

a year ago
Created attachment 8867547 [details]
Firefox_Nightly_55.0a1 (2017-05-14) (32 bits).txt
/shutdown is not in the webdriver spec. The Java bindings should not be sending this over, they should just be controlling the process themselves. When DELETE session/<session id> is called we would shutdown geckodriver and firefox. 

Please raise a Selenium issue for them to follow up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 13

a year ago
Just for my understanding:

You are stating that the expected results as show below
[[FirefoxDriver: firefox on ANY (cfce20a5-24f8-4827-bf7b-b14ac4c43db2)] -> xpath: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4]
clicked
[[FirefoxDriver: firefox on ANY (cfce20a5-24f8-4827-bf7b-b14ac4c43db2)] -> xpath: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[1]/h4]
clicked

are not available/valid because Selenium is sending this invalid /shutdown command by the end of the process?
(Reporter)

Comment 14

a year ago
I removed the statement driver.quit() that generates the invalid /shutdown command and the issue is remaining while no /shutdown command is send, so please reopen this issue.

See the log below


1494856823570	geckodriver	INFO	Listening on 127.0.0.1:35034
1494856824173	geckodriver::marionette	INFO	Starting browser \\?\C:\Program Files (x86)\Nightly\firefox.exe with args ["-marionette"]
1494856825815	addons.manager	ERROR	startup failed: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIFile.create]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 70"  data: no] Stack trace: FileUtils_getDir()@resource://gre/modules/FileUtils.jsm:70 < FileUtils_getFile()@resource://gre/modules/FileUtils.jsm:42 < validateBlocklist()@resource://gre/modules/AddonManager.jsm:651 < startup()@reJsaovuarSccer:i/p/tg reer/rmoord:u lreess/oAudrdcoen:Man/a/ggerre./jmsomd:u8l1e1s /<A dsdtoanrMtaunpa()g@erre.sjosumr,c e://gre/modules/AddonManager.jsm:3079 < obslerivnee( )1@5r9e1so:u rNcSe_:E/R/RgOrRe_/NcOoTm_pIoNnIeTnItAsL/IaZdEdDo:n MAadndaogneMr.ajnsa:g6e5r
 
is not initialized
1494856826192	geckodriver::marionette	TRACE	  connection attempt 0/600
1494856828288	geckodriver::marionette	TRACE	  connection attempt 1/600
1494856830391	geckodriver::marionette	TRACE	  connection attempt 2/600
Unable to read VR Path Registry from C:\Users\FrancisANDRE\AppData\Local\openvr\openvrpaths.vrpath
[Child 9980] WARNING: pipe error: 109: file c:/builds/moz2_slave/m-cen-w32-ntly-000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
1494856832493	geckodriver::marionette	TRACE	  connection attempt 3/600
1494856834593	geckodriver::marionette	TRACE	  connection attempt 4/600
1494856836115	Marionette	DEBUG	Setting recommended pref toolkit.cosmeticAnimations.enabled to false
1494856836117	Marionette	DEBUG	Setting recommended pref datareporting.policy.dataSubmissionPolicyAccepted to false
1494856836119	Marionette	INFO	Listening on port 54797
Unable to read VR Path Registry from C:\Users\FrancisANDRE\AppData\Local\openvr\openvrpaths.vrpath
JavaScript error: resource://gre/modules/AddonManager.jsm, line 2506: NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
1494856836206	geckodriver::marionette	DEBUG	Connected to Marionette on localhost:54797
1494856838607	Marionette	DEBUG	Accepted connection 0 from 127.0.0.1:54820
1494856838677	geckodriver::marionette	TRACE	← {"applicationType":"gecko","marionetteProtocol":3}
1494856838677	geckodriver::marionette	TRACE	→ 62:[0,1,"newSession",{"capabilities":{"desiredCapabilities":{}}}]
1494856838697	Marionette	TRACE	0 -> [0,1,"newSession",{"capabilities":{"desiredCapabilities":{}}}]
1494856838701	Marionette	CONFIG	Matched capabilities: {"browserName":"firefox","browserVersion":"55.0a1","platformName":"windows_nt","platformVersion":"6.1","pageLoadStrategy":"normal","acceptInsecureCerts":false,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000},"rotatable":false,"specificationLevel":0,"moz:processID":6212,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.2Yeto7kToiiI","moz:accessibilityChecks":false}
1494856838750	Marionette	DEBUG	loaded listener.js
1494856838771	Marionette	TRACE	0 <- [1,1,null,{"sessionId":"d22a871f-10f2-40f0-9fcf-6e680aac0e7c","capabilities":{"browserName":"firefox","browserVersion":"55.0a1","platformName":"windows_nt","platformVersion":"6.1","pageLoadStrategy":"normal","acceptInsecureCerts":false,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000},"rotatable":false,"specificationLevel":0,"moz:processID":6212,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.2Yeto7kToiiI","moz:accessibilityChecks":false}}]
1494856838775	geckodriver::marionette	TRACE	← [1,1,null,{"sessionId":"d22a871f-10f2-40f0-9fcf-6e680aac0e7c","capabilities":{"browserName":"firefox","browserVersion":"55.0a1","platformName":"windows_nt","platformVersion":"6.1","pageLoadStrategy":"normal","acceptInsecureCerts":false,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000},"rotatable":false,"specificationLevel":0,"moz:processID":6212,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.2Yeto7kToiiI","moz:accessibilityChecks":false}}]
1494856838776	webdriver::server	DEBUG	← 200 OK {"value": {"sessionId":"d22a871f-10f2-40f0-9fcf-6e680aac0e7c","capabilities":{"acceptInsecureCerts":false,"browserName":"firefox","browserVersion":"55.0a1","moz:accessibilityChecks":false,"moz:processID":6212,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.2Yeto7kToiiI","pageLoadStrategy":"normal","platformName":"windows_nt","platformVersion":"6.1","rotatable":false,"specificationLevel":0,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000}}}}
mai 15, 2017 4:00:38 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFOS: Detected dialect: W3C
1494856838836	webdriver::server	DEBUG	→ POST /session/d22a871f-10f2-40f0-9fcf-6e680aac0e7c/url {"url":"http://localhost:8080/nicedemo"}
1494856838836	geckodriver::marionette	TRACE	→ 52:[0,2,"get",{"url":"http://localhost:8080/nicedemo"}]
1494856839867	Marionette	TRACE	0 -> [0,2,"get",{"url":"http://localhost:8080/nicedemo"}]
1494856839894	Marionette	DEBUG	Received DOM event "beforeunload" for "about:blank"
1494856839972	Marionette	DEBUG	Received DOM event "pagehide" for "about:blank"
1494856839972	Marionette	DEBUG	Received DOM event "unload" for "about:blank"
1494856839980	Marionette	DEBUG	Received DOM event "DOMContentLoaded" for "http://localhost:8080/nicedemo/"
1494856839983	Marionette	DEBUG	Received DOM event "pageshow" for "http://localhost:8080/nicedemo/"
1494856840004	Marionette	TRACE	0 <- [1,2,null,{}]
1494856840035	geckodriver::marionette	TRACE	← [1,2,null,{}]
1494856840035	webdriver::server	DEBUG	← 200 OK {"value": {}}
1494856840045	webdriver::server	DEBUG	→ POST /session/d22a871f-10f2-40f0-9fcf-6e680aac0e7c/element {"value":"/html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4","using":"xpath"}
1494856840046	geckodriver::marionette	TRACE	→ 128:[0,3,"findElement",{"using":"xpath","value":"/html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4"}]
1494856840060	Marionette	TRACE	0 -> [0,3,"findElement",{"using":"xpath","value":"/html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4"}]
1494856840084	Marionette	TRACE	0 <- [1,3,{"error":"no such element","message":"Unable to locate element: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4","stacktrace":"WebDriverError@chrome://marionette/content/error.js:213:5\nNoSuchElementError@chrome://marionette/content/error.js:421:5\nelement.find/</<@chrome://marionette/content/element.js:278:16\npromise callback*element.find/<@chrome://marionette/content/element.js:264:5\nelement.find@chrome://marionette/content/element.js:254:10\nfindElementContent@chrome://marionette/content/listener.js:1260:18\nTaskImpl_run@resource://gre/modules/Task.jsm:321:42\nTaskImpl@resource://gre/modules/Task.jsm:279:3\nasyncFunction@resource://gre/modules/Task.jsm:254:14\nTask_spawn@resource://gre/modules/Task.jsm:168:12\nTaskImpl_handleResultValue@resource://gre/modules/Task.jsm:391:16\nTaskImpl_run@resource://gre/modules/Task.jsm:329:15\nTaskImpl@resource://gre/modules/Task.jsm:279:3\nasyncFunction@resource://gre/modules/Task.jsm:254:14\nTask_spawn@resource://gre/modules/Task.jsm:168:12\ndispatch/<@chrome://marionette/content/listener.js:428:15\n"},null]
1494856840087	geckodriver::marionette	TRACE	← [1,3,{"error":"no such element","message":"Unable to locate element: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4","stacktrace":"WebDriverError@chrome://marionette/content/error.js:213:5\nNoSuchElementError@chrome://marionette/content/error.js:421:5\nelement.find/</<@chrome://marionette/content/element.js:278:16\npromise callback*element.find/<@chrome://marionette/content/element.js:264:5\nelement.find@chrome://marionette/content/element.js:254:10\nfindElementContent@chrome://marionette/content/listener.js:1260:18\nTaskImpl_run@resource://gre/modules/Task.jsm:321:42\nTaskImpl@resource://gre/modules/Task.jsm:279:3\nasyncFunction@resource://gre/modules/Task.jsm:254:14\nTask_spawn@resource://gre/modules/Task.jsm:168:12\nTaskImpl_handleResultValue@resource://gre/modules/Task.jsm:391:16\nTaskImpl_run@resource://gre/modules/Task.jsm:329:15\nTaskImpl@resource://gre/modules/Task.jsm:279:3\nasyncFunction@resource://gre/modules/Task.jsm:254:14\nTask_spawn@resource://gre/modules/Task.jsm:168:12\ndispatch/<@chrome://marionette/content/listener.js:428:15\n"},null]
1494856840089	webdriver::server	DEBUG	← 404 Not Found {"value":{"error":"no such element","message":"Unable to locate element: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4","stacktrace":"stack backtrace:\n   0:           0x489f6f - <no info>\n   1:           0x48ad59 - <no info>\n   2:           0x43a15d - <no info>\n   3:           0x4474c9 - <no info>\n   4:           0x445208 - <no info>\n   5:           0x41ddb1 - <no info>\n   6:           0x4091c7 - <no info>\n   7:           0x6bc939 - <no info>\n   8:           0x415a19 - <no info>\n   9:           0x6b6e43 - <no info>\n  10:         0x774d59cd - BaseThreadInitThunk"}}
(In reply to zosrothko from comment #13)
> Just for my understanding:
> 
> are not available/valid because Selenium is sending this invalid /shutdown
> command by the end of the process?

Yup exactly.
(In reply to zosrothko from comment #14)
> I removed the statement driver.quit() that generates the invalid /shutdown
> command and the issue is remaining while no /shutdown command is send, so
> please reopen this issue.
> 
> See the log below
> 

... log reduced to the next 404

> 
> 1494856840089	webdriver::server	DEBUG	← 404 Not Found
> {"value":{"error":"no such element","message":"Unable to locate element:
> /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/
> a[2]/h4","stacktrace":"stack backtrace:\n   0:           0x489f6f - <no
> 

There is an issue with your locator. If a driver can't find an element it should be returning a 404. See https://w3c.github.io/webdriver/webdriver-spec.html#dfn-no-such-element
(Reporter)

Comment 17

a year ago
That is the purpose of this issue named "Invalid 404 Not Found". The locator is CORRECT and as stated before when there is a breakpoint at line 61, the lcaotor returns the proper element which is displayed as 

[[FirefoxDriver: firefox on ANY (42e5d257-6acd-46e5-8045-84cebd14e0fb)] -> xpath: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4]


See in the log below from a debugging session

1494860017575	geckodriver	INFO	Listening on 127.0.0.1:36395
1494860018206	geckodriver::marionette	INFO	Starting browser \\?\C:\Program Files (x86)\Nightly\firefox.exe with args ["-marionette"]
1494860018770	addons.manager	ERROR	startup failed: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIFile.create]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 70"  data: no] Stack trace: FileUtils_getDir()@resource://gre/modules/FileUtils.jsm:70 < FileUtils_getFile()@resource://gre/modules/FileUtils.jsm:42 < validateBlocklist()@resource://gre/modules/AddonManager.jsm:651 < startup()@resource://gre/modules/AddonManager.jsm:811 < startup()@resource://gre/modules/AddonManager.jsm:3079 < observe()@resource://gre/components/addonManager.js:65
JavaScript error: resource://gre/modules/AddonManager.jsm, line 1591: NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
1494860020232	geckodriver::marionette	TRACE	  connection attempt 0/600
Unable to read VR Path Registry from C:\Users\FrancisANDRE\AppData\Local\openvr\openvrpaths.vrpath
JavaScript error: resource://gre/modules/AddonManager.jsm, line 2506: NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
1494860020513	Marionette	DEBUG	Setting recommended pref toolkit.cosmeticAnimations.enabled to false
1494860020515	Marionette	DEBUG	Setting recommended pref datareporting.policy.dataSubmissionPolicyAccepted to false
1494860020517	Marionette	INFO	Listening on port 56507
1494860021332	geckodriver::marionette	DEBUG	Connected to Marionette on localhost:56507
1494860021335	Marionette	DEBUG	Accepted connection 0 from 127.0.0.1:56525
1494860021336	geckodriver::marionette	TRACE	← {"applicationType":"gecko","marionetteProtocol":3}
1494860021336	geckodriver::marionette	TRACE	→ 62:[0,1,"newSession",{"capabilities":{"desiredCapabilities":{}}}]
1494860021337	Marionette	TRACE	0 -> [0,1,"newSession",{"capabilities":{"desiredCapabilities":{}}}]
1494860021341	Marionette	CONFIG	Matched capabilities: {"browserName":"firefox","browserVersion":"55.0a1","platformName":"windows_nt","platformVersion":"6.1","pageLoadStrategy":"normal","acceptInsecureCerts":false,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000},"rotatable":false,"specificationLevel":0,"moz:processID":11204,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.OAxvxyEQptWY","moz:accessibilityChecks":false}
1494860021382	Marionette	DEBUG	loaded listener.js
1494860021394	Marionette	TRACE	0 <- [1,1,null,{"sessionId":"42e5d257-6acd-46e5-8045-84cebd14e0fb","capabilities":{"browserName":"firefox","browserVersion":"55.0a1","platformName":"windows_nt","platformVersion":"6.1","pageLoadStrategy":"normal","acceptInsecureCerts":false,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000},"rotatable":false,"specificationLevel":0,"moz:processID":11204,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.OAxvxyEQptWY","moz:accessibilityChecks":false}}]
1494860021396	geckodriver::marionette	TRACE	← [1,1,null,{"sessionId":"42e5d257-6acd-46e5-8045-84cebd14e0fb","capabilities":{"browserName":"firefox","browserVersion":"55.0a1","platformName":"windows_nt","platformVersion":"6.1","pageLoadStrategy":"normal","acceptInsecureCerts":false,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000},"rotatable":false,"specificationLevel":0,"moz:processID":11204,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.OAxvxyEQptWY","moz:accessibilityChecks":false}}]
1494860021396	webdriver::server	DEBUG	← 200 OK {"value": {"sessionId":"42e5d257-6acd-46e5-8045-84cebd14e0fb","capabilities":{"acceptInsecureCerts":false,"browserName":"firefox","browserVersion":"55.0a1","moz:accessibilityChecks":false,"moz:processID":11204,"moz:profile":"C:\\Users\\FRANCI~1\\AppData\\Local\\Temp\\rust_mozprofile.OAxvxyEQptWY","pageLoadStrategy":"normal","platformName":"windows_nt","platformVersion":"6.1","rotatable":false,"specificationLevel":0,"timeouts":{"implicit":0,"pageLoad":300000,"script":30000}}}}
mai 15, 2017 4:53:41 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFOS: Detected dialect: W3C
1494860021453	webdriver::server	DEBUG	→ POST /session/42e5d257-6acd-46e5-8045-84cebd14e0fb/url {"url":"http://localhost:8080/nicedemo"}
1494860021454	geckodriver::marionette	TRACE	→ 52:[0,2,"get",{"url":"http://localhost:8080/nicedemo"}]
1494860021455	Marionette	TRACE	0 -> [0,2,"get",{"url":"http://localhost:8080/nicedemo"}]
1494860021480	Marionette	DEBUG	Received DOM event "beforeunload" for "about:blank"
1494860021515	Marionette	DEBUG	Received DOM event "pagehide" for "about:blank"
1494860021515	Marionette	DEBUG	Received DOM event "unload" for "about:blank"
1494860021524	Marionette	DEBUG	Received DOM event "DOMContentLoaded" for "http://localhost:8080/nicedemo/"
1494860021526	Marionette	DEBUG	Received DOM event "pageshow" for "http://localhost:8080/nicedemo/"
1494860021540	Marionette	TRACE	0 <- [1,2,null,{}]
1494860021548	geckodriver::marionette	TRACE	← [1,2,null,{}]
1494860021548	webdriver::server	DEBUG	← 200 OK {"value": {}}
1494860027035	webdriver::server	DEBUG	→ POST /session/42e5d257-6acd-46e5-8045-84cebd14e0fb/element {"value":"/html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4","using":"xpath"}
1494860027036	geckodriver::marionette	TRACE	→ 128:[0,3,"findElement",{"using":"xpath","value":"/html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4"}]
1494860027038	Marionette	TRACE	0 -> [0,3,"findElement",{"using":"xpath","value":"/html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4"}]
1494860027044	Marionette	TRACE	0 <- [1,3,null,{"value":{"element-6066-11e4-a52e-4f735466cecf":"b4784b34-799c-4db2-995e-7077bc063e7c","ELEMENT":"b4784b34-799c-4db2-995e-7077bc063e7c"}}]
1494860027044	geckodriver::marionette	TRACE	← [1,3,null,{"value":{"element-6066-11e4-a52e-4f735466cecf":"b4784b34-799c-4db2-995e-7077bc063e7c","ELEMENT":"b4784b34-799c-4db2-995e-7077bc063e7c"}}]
1494860027044	webdriver::server	DEBUG	← 200 OK {"value":{"element-6066-11e4-a52e-4f735466cecf":"b4784b34-799c-4db2-995e-7077bc063e7c"}}
[[FirefoxDriver: firefox on ANY (42e5d257-6acd-46e5-8045-84cebd14e0fb)] -> xpath: /html/body/div/div[@class='row'][2]/div/div/div/div[@class='row'][2]/div/a[2]/h4]
1494860035829	webdriver::server	DEBUG	→ GET /session/42e5d257-6acd-46e5-8045-84cebd14e0fb/element/b4784b34-799c-4db2-995e-7077bc063e7c/text 
1494860035830	geckodriver::marionette	TRACE	→ 68:[0,4,"getElementText",{"id":"b4784b34-799c-4db2-995e-7077bc063e7c"}]
1494860035832	Marionette	TRACE	0 -> [0,4,"getElementText",{"id":"b4784b34-799c-4db2-995e-7077bc063e7c"}]
1494860035880	Marionette	TRACE	0 <- [1,4,null,{"value":"List"}]
1494860035880	geckodriver::marionette	TRACE	← [1,4,null,{"value":"List"}]
1494860035880	webdriver::server	DEBUG	← 200 OK {"value":"List"}
(Reporter)

Updated

a year ago
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Version: 53 Branch → 55 Branch
If adding a breakpoint that induces a pause before the element is returned successfully, this likely means you need to wait for the element to become visible before locating it.  You can do this using an explicit wait condition or by increasing the session implicit element search duration.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → INVALID
(Reporter)

Comment 19

a year ago
OK that's right... adding a pause makes the element visible...it was not necessary before switching to the configuration used, hence this issue. Thanks for the tip.
Status: RESOLVED → VERIFIED
I want to add that this is not a side-effect with the get() command:

1494856839867	Marionette	TRACE	0 -> [0,2,"get",{"url":"http://localhost:8080/nicedemo"}]
1494856839894	Marionette	DEBUG	Received DOM event "beforeunload" for "about:blank"
1494856839972	Marionette	DEBUG	Received DOM event "pagehide" for "about:blank"
1494856839972	Marionette	DEBUG	Received DOM event "unload" for "about:blank"
1494856839980	Marionette	DEBUG	Received DOM event "DOMContentLoaded" for "http://localhost:8080/nicedemo/"
1494856839983	Marionette	DEBUG	Received DOM event "pageshow" for "http://localhost:8080/nicedemo/"
1494856840004	Marionette	TRACE	0 <- [1,2,null,{}]

We correctly return here after the pageshow event. As it looks like the element which is not found is lazily added to the document, and as such the extra sleep is necessary. Or instead of the pause do a continuous check if the element is present, each 100ms or so. Not sure if your binding is offering something like that.
You need to log in before you can comment on or make changes to this bug.