Closed Bug 1362424 Opened 3 years ago Closed 3 years ago

linux64-qr debug R-e10s(R8,Ru8) permafail in editor/reftests/672709-ref.html, editor/reftests/338427-1.html

Categories

(Core :: Graphics: WebRender, defect, P3)

Other Branch
defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

These tests started permafailing with a recent merge from m-c to graphics. The failure doesn't happen on m-c itself, so it's some interaction between stuff on m-c and stuff on graphics. I'm gonna try bisecting to see where it's coming from.
It's hard to see how that could be possible. Bug 1360001 should have any noticeable behaviour impact.
Yeah I'm not sure. I'm noticing this failure on m-c now as well, even though the graphics branch hasn't been merged to m-c. So that seems to indicate that it's just an intermittent failure that started on m-c but happens more frequently when combined with gfx. I'll finish bisecting the m-c regression.

bisection at [1] narrows range to [2].

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad95ad2b02dc2c8c7304e20eb0ebc1193fb828a9
[2] https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=78b648c9c7d1&tochange=9c7f749e9015
Shoot. Looks like the bisection produced an incorrect result, it's happening on autoland even before bug 1359952 landed. Not sure where to go from here :(

FWIW bug 1361820 is being used for the intermittent failures on m-c.
No longer blocks: 1359952
See Also: → 1361820
I took a closer look at the failures. It's almost certainly being caused by bug 1354641. The spellchecking code is taking too long, causing the reftest to time out. And then it leaves WR in a bad state causing the next test (338427-1.html) to also fail. I'm going to skip the bad test to get our R8 job green again, and then try to get the QR reftests running on autoland and inbound as well to catch these regressions sooner rather than wasting time bisecting afterwards.

Try push with the test skipped: https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e62aeb1c24450f7b8dd3e5303f7e506bed8cbeb
Blocks: 1354641
No longer blocks: 1360001
Assignee: nobody → bugmail
Comment on attachment 8865641 [details]
Bug 1362424 - Skip a spellchecking reftest that is now permafailing on QuantumRender builds.

https://reviewboard.mozilla.org/r/137254/#review140306
Attachment #8865641 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e426d513c19c
Skip a spellchecking reftest that is now permafailing on QuantumRender builds. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/e426d513c19c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
This can be re-enabled now, FWIW.  Bug 1354641 was backed out.
Looks like it was accidentally re-enabled already in https://hg.mozilla.org/mozilla-central/rev/d5b141b9583e#l3.126 by an unrelated stylo change. So nothing to do here.
You need to log in before you can comment on or make changes to this bug.