Crash in core::result::unwrap_failed<T> | webrender::renderer::Renderer::submit_batch

RESOLVED WORKSFORME

Status

()

Core
Graphics: WebRender
--
critical
RESOLVED WORKSFORME
a year ago
9 months ago

People

(Reporter: marcia, Unassigned)

Tracking

(Blocks: 2 bugs, {crash})

55 Branch
All
Windows 10
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 affected, firefox56 unaffected, firefox57 unaffected)

Details

(Whiteboard: [gfx-noted], crash signature)

This bug was filed from the Socorro interface and is 
report bp-092ece8e-4c16-4d21-89eb-c65250170504.
=============================================================

Seen while looking at nightly crash stats - http://bit.ly/2pdsNBG. Crashes started using 20170503030212. 

Some gfx/webrender/src/renderer and rust in the signature.

Comment 1

a year ago
I think this could be the shader compilation issues from bug 1361434.
See Also: → bug 1361434
Whiteboard: [gfx-noted]
The WR update from bug 1359744 just got merged to central, so if this is the shader compilation issue from bug 1361434 it should go away in the next nightly. (May 9 onwards)
Still around in the May 13 nightly.
Also, I filed bug 1364706 on Socorro to make this crash signature more useful, so the signature will change to:
  core::result::unwrap_failed<T> | webrender::renderer::Renderer::submit_batch
once that lands.
I think we need to add more logging in webrender and ensure that shows up in crash reports in order to actually get to the bottom of crashes like these.
There's another shader compilation issue reported in upstream WR, https://github.com/servo/webrender/issues/1251 - might or might not be the same as this. Without the logging we can't really say.
Crash Signature: [@ core::result::unwrap_failed<T>] → [@ core::result::unwrap_failed<T>] [@ core::result::unwrap_failed<T> | webrender::renderer::Renderer::submit_batch]
Summary: Crash in core::result::unwrap_failed<T> → Crash in core::result::unwrap_failed<T> | webrender::renderer::Renderer::submit_batch

Updated

11 months ago
Duplicate of this bug: 1379346

Updated

11 months ago
status-firefox56: --- → affected
Hardware: x86 → All
Priority: -- → P3
Blocks: 1357819, 1386669
No longer depends on: 1357819

Updated

10 months ago
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
status-firefox56: affected → unaffected
status-firefox57: --- → unaffected
This stopped after the 20170809100326 buildid.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME

Updated

9 months ago
Priority: P2 → --
Whiteboard: [wr-mvp] [gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.