Client record is not updated with fxaDeviceId after registration

RESOLVED FIXED

Status

()

Firefox for iOS
Sync
P1
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: st3fan, Assigned: jhugman)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

(Whiteboard: [MobileCore])

Attachments

(2 attachments)

(Reporter)

Description

7 months ago
AutoPush from Desktop currently does not work because iOS does not store the fxaDeviceId in its own client record. It needs to be in there we currently maintain two lists of devices. One list in FxA, one list in sync (client records) and this fxaDeviceId is the primary key between them.

Marking this as a blocker for 8.0



The problem is there is no `fxaDeviceId` in the iOS client record.

After device registration the fxaDeviceId needs to be set.

Android Example: http://searchfox.org/mozilla-central/source/mobile/android/services/src/main/java/org/mozilla/gecko/sync/stage/SyncClientsEngineStage.java#479

Desktop Example: 
http://searchfox.org/mozilla-central/source/services/sync/modules/engines/clients.js#843

See attached log.
(Reporter)

Comment 1

7 months ago
Created attachment 8864936 [details]
no-deviceid.png
See Also: → bug 1261169

Updated

7 months ago
Iteration: 1.20 → 1.21
(Assignee)

Updated

7 months ago
Assignee: nobody → jhugman
Status: NEW → ASSIGNED
(Reporter)

Updated

7 months ago
tracking-fxios: 8.0+ → +
(Assignee)

Comment 2

7 months ago
Created attachment 8866541 [details] [review]
Link to Github pull-request: https://github.com/mozilla-mobile/firefox-ios/pull/2718
Attachment #8866541 - Flags: review?(sleroux)
Attachment #8866541 - Flags: review?(sleroux) → review+
(Assignee)

Comment 3

7 months ago
Question answered in PR. 

Merged into master.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.