2.42 - 3.51% damp (linux64, windows7-32) regression on push a9339d769d2b03f5a21b8e7a804a0d2d528af1af (Fri May 5 2017)

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
2 years ago
Last year

People

(Reporter: jmaher, Assigned: rickychien)

Tracking

({perf, regression, talos-regression})

53 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Talos has detected a Firefox performance regression from push a9339d769d2b03f5a21b8e7a804a0d2d528af1af. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  damp summary windows7-32 opt      308.41 -> 319.23
  2%  damp summary linux64 opt          301.08 -> 308.36


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=6413

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Looking at the code which landed and the subtests in the compare view:
https://treeherder.mozilla.org/perf.html#/comparesubtest?originalProject=autoland&originalRevision=86de1de2f3f39bc225985f182ab992c97648f8a1&newProject=autoland&newRevision=a9339d769d2b03f5a21b8e7a804a0d2d528af1af&originalSignature=36adf201cb660409c00544b0a576c6f86c3eb669&newSignature=36adf201cb660409c00544b0a576c6f86c3eb669&framework=1

it looks very much related!

:rickychien, can you take a look at this regression and help determine if we can fix this, should back it out, or should accept it and move on?
Component: Untriaged → Developer Tools: Netmonitor
Flags: needinfo?(rchien)
Thanks for reporting this regression! I think it's ok to move on and I can take a look in these days.
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: needinfo?(rchien)
Depends on: 1365635
Could you tell me which talos test I should run? I cannot figure it from https://treeherder.mozilla.org/perf.html#/alerts?id=6413.
Flags: needinfo?(jmaher)
if you are pushing to try, then you need |./mach try -b o -p win32,linux64 -u none -t g2-e10s|.

locally it would be: |./mach talos-test -a g2|


As a note, we are not running non-e10s talos tests as that is our target for Firefox 57 (e10s only) and we need to focus our available machines on e10s performance.  This looks to be a non-e10s only regression- ideally we should make sure there are no e10s issues and then call this good.
Flags: needinfo?(jmaher)
Sorry I'm still not clear. According to https://treeherder.mozilla.org/perf.html#/alerts?id=6413, the damp regression looks like to happen on both e10s and non-e10s modes.

And |./mach talos-test -a g2| didin't work for me and threw:

FATAL - Test name is missing or invalid
FATAL - Running post_fatal callback...
FATAL - Exiting -1

when running it locally.
Flags: needinfo?(jmaher)
oh, locally needs to be: |./mach talos-test -a damp|

I really had a bad typo earlier!  I looked at the data in the bug, not what alerts came in after filing the bug, so linux64 seems to be the platform where we have a flagged e10s damp regression.
Flags: needinfo?(jmaher)
I agree that the overall trend is great here.  If you feel the regression is acceptable to take, then lets take it and move on!  It is great to see the big picture and also good to understand small details.
Flags: needinfo?(jmaher)
Thanks for your agreement. Let's take it and move on!
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
WONTFIX seems more appropriate since we're choosing to accept the regression.
Resolution: FIXED → WONTFIX

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.