Closed Bug 1362746 Opened 4 years ago Closed 4 years ago

55.0a.1 file size of download UI missing information

Categories

(Firefox :: Downloads Panel, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1354568

People

(Reporter: unityole, Unassigned)

Details

(Keywords: nightly-community)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170428030259

Steps to reproduce:

firefox 45 to 52 download UI shows all info.. but nightly 55.0a.1 these info are removed?

process to reproduce: download a file, any file, once completed firefox shows status: complete, shows size of file how much it is downloaded, shows the website its downloaded from.


Actual results:

download UI shows status: complete
download UI does not show total size of file that is complete or completed
UI does not show the website its downloaded from.


Expected results:

shows status complete/failed etc
shows size of file downloaded when it complete/fails
shows in UI website its from
Component: Untriaged → Downloads Panel
I can confirm the change. Using MozRegression I found that the following bug introduced the change: https://bugzilla.mozilla.org/show_bug.cgi?id=1282662
After consulting the mock-up here : https://mozilla.invisionapp.com/share/4Y6ZZH1E8#/screens/162255352
it looks like it's an intended change, not a regression.

You can still see the size and domain but you need to access the library window by clicking on the "Show All Downloads" button.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
(In reply to Arnaud J from comment #1)
> I can confirm the change. Using MozRegression I found that the following bug
> introduced the change: https://bugzilla.mozilla.org/show_bug.cgi?id=1282662
> After consulting the mock-up here :
> https://mozilla.invisionapp.com/share/4Y6ZZH1E8#/screens/162255352
> it looks like it's an intended change, not a regression.
> 
> You can still see the size and domain but you need to access the library
> window by clicking on the "Show All Downloads" button.

can this change be reverted? this is extra work for people who wish to see the info right away. instead of just click on the download drop down now i have to go to library window to view it and its extra clicks each time i want to check, this is going backward for power users or for anyone for that matter.

is there an about:config option thing where i can maybe set to false or true to have information showing again without having to go to library?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I have asked our designer to take a look in bug 1354568, where a use case for the size has already been mentioned.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1354568
You need to log in before you can comment on or make changes to this bug.