If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't select long text in JSON Viewer

RESOLVED DUPLICATE of bug 1328008

Status

()

Firefox
Developer Tools: JSON Viewer
RESOLVED DUPLICATE of bug 1328008
5 months ago
4 months ago

People

(Reporter: Oriol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
1. Load data:application/json,["abcdefghijklmnopqrstuvwxyz0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ"]
2. Attempt to select the string

First attempt: mousedown after initial quote, mouseup before ending quote
Result:
 1. Mousedown + mousemove select properly
 2. Mouseup shrinks the string and the selection is lost

Second attempt: double click the string
Result:
 1. First click shrinks the string
 2. Second click briefly selects the clicked half of the shrinked string
 3. Immediately, the whole string is restored and the selection is lost

Third attempt: triple click the string
Result:
 1. First click shrinks the string
 2. Second click briefly selects the clicked half of the shrinked string
 3. Immediately, the whole string is restored and the selection is lost
 4. Third click selects the whole string, including quotes
 5. Immediately, the string shrinks. The selection is not lost, but I wanted to select the original string, not the shrinked one

So frustrating.

I think clicking a long string should not toggle it. It should only be toggled by clicking the tree icon at the left.
(Reporter)

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1328008
You need to log in before you can comment on or make changes to this bug.