In some cases Thunderbird 52.1.0 saves attachment in Base64-encoded form

RESOLVED DUPLICATE of bug 1361422

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1361422
9 months ago
8 months ago

People

(Reporter: yup, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.41 KB, text/plain
Details
(Reporter)

Description

9 months ago
Created attachment 8865136 [details]
000003e6.eml

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120202951

Steps to reproduce:

Thunderbird 52.1.0 (but not earlier versions) incorrectly saves to disk Base64-encoded attachment from a single-part (non-multipart) message.

Steps to reproduce:
1. Open a testcase EML (000003e6.eml)
2. Save attachment to disk.


Actual results:

Thunderbird 52.1.0 saves such attachment in Base64-encoded form.


Expected results:

The attached file must be decoded.
Attachment #8865136 - Attachment mime type: message/rfc822 → text/plain
This is a duplicate of Bug 1361422.
It is already fixed on trunk and the upcoming TB 54 beta. TB 52.2 ESR will follow.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1361422

Comment 3

9 months ago
Hello!
I have downloaded Daily thunderbird-55.0a1.ru and Earlybird thunderbird-54.0a2.ru and it still does not work properly.
may be i do somthing wrong?
should i try hourly?
(In reply to jazis from comment #3)
> I have downloaded Daily thunderbird-55.0a1.ru and Earlybird
> thunderbird-54.0a2.ru and it still does not work properly.
> may be i do somthing wrong?
Yes. Localised Daily versions (TB 55) have not received updates since the end of April, bug 1362884. The Aurora Channel (TB 54) has been discontinued.

Try a Daily TB 55 en-US build or a Daily TB 52 ESR build:
http://ftp.mozilla.org/pub/thunderbird/nightly/2017/05/2017-05-10-03-02-03-comm-esr52/
(Reporter)

Comment 5

8 months ago
(In reply to Jorg K (GMT+2) from comment #4)
> Try a Daily TB 55 en-US build or a Daily TB 52 ESR build:
> http://ftp.mozilla.org/pub/thunderbird/nightly/2017/05/2017-05-10-03-02-03-
> comm-esr52/
Yes, this version displays and saves the image from my example correctly.
(The real person who discovered this bug is jazis from comment 3, and that example was provided to me by him.)
You need to log in before you can comment on or make changes to this bug.