Intermittent dom/media/test/test_media_selection.html | seek-short.webm duration (NaN) should be around 0.23

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: alwu)

Tracking

(Blocks: 1 bug, {intermittent-failure, regression})

unspecified
mozilla55
ARM
Android
intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

(Whiteboard: [fennec-scouting] [stockwell fixed:product])

Attachments

(2 attachments)

Updated

2 years ago
tracking-fennec: --- → ?
Has Regression Range: --- → yes
Keywords: regression
OS: Unspecified → Android
Hardware: Unspecified → ARM
Summary: Intermittent dom/media/test/test_media_selection.html | seek-short.webm duration (NaN) should be around 0.23 → dom/media/test/test_media_selection.html | seek-short.webm duration (NaN) should be around 0.23
10 failures in 770 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 10

Platform breakdown:
* android-5-1-armv7-api15: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1362793&startday=2017-05-01&endday=2017-05-07&tree=all

Updated

2 years ago
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected

Comment 2

2 years ago
This isn't intermittent on Android 5.1 but it doesn't appear in the suggested bugs in Treeherder. Adding it to see if that helps with matching.
Summary: dom/media/test/test_media_selection.html | seek-short.webm duration (NaN) should be around 0.23 → Intermittent dom/media/test/test_media_selection.html | seek-short.webm duration (NaN) should be around 0.23
(In reply to Bob Clary [:bc:] from comment #2)
> This isn't intermittent on Android 5.1 but it doesn't appear in the
> suggested bugs in Treeherder. Adding it to see if that helps with matching.

i guess you have to set the keyword too
Keywords: intermittent-failure
tracking-fennec: ? → +

Updated

2 years ago
Whiteboard: [fennec-scouting]
51 failures in 879 pushes (0.058 failures/push) were associated with this bug in the last 7 days. 

This is the #21 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-central: 50
* mozilla-inbound: 1

Platform breakdown:
* android-5-1-armv7-api15: 50
* android-4-4-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1362793&startday=2017-05-08&endday=2017-05-14&tree=all
:bc - do you have a plan here? Disable on 5.1?
Flags: needinfo?(bob)
Whiteboard: [fennec-scouting] → [fennec-scouting] [stockwell needswork]

Comment 6

2 years ago
I'd rather not. I'd like to find who regressed this and get them to fix it or back it out. That is *way* down my list of things to do however.
Flags: needinfo?(bob)
This test is perma-fail on autophone Android 5.1, on mozilla-central, since https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=8872ad4d52b6b517dc9d2a9f62c5c75ceda18790. There are lots of changes in that merge but I wonder if this might be related to the changes for bug 1357639.

:alwu - what do you think?
Flags: needinfo?(alwu)

Updated

2 years ago
See Also: → bug 1364256
(Assignee)

Comment 8

2 years ago
No, the bug 1357639 is just adding new robocop test, it won't affect the DOM media test. But I can investigate it later, keep NI.
(Assignee)

Comment 9

2 years ago
I think the fail might be caused by bug1361944, but I'm still looking for root cause.
Assignee: nobody → alwu
(Assignee)

Updated

2 years ago
Depends on: 1361944
Flags: needinfo?(alwu)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 14

2 years ago
mozreview-review
Comment on attachment 8868936 [details]
Bug 1362793 - part1 : shouldn't shutdown decoder too early.

https://reviewboard.mozilla.org/r/140586/#review144402
Attachment #8868936 - Flags: review?(jwwang) → review+

Comment 15

2 years ago
mozreview-review
Comment on attachment 8869298 [details]
Bug 1362793 - part2 : add test.

https://reviewboard.mozilla.org/r/140854/#review144404

P1 and P2 should be combined. Also add a new test case to ensuer we don't regress it in the future.
The test case involes a special file where decoding errors will be encountered after decoding metadata. We test the duration when 'error' is fired.
Attachment #8869298 - Flags: review?(jwwang) → review+
(Assignee)

Comment 16

2 years ago
(In reply to JW Wang [:jwwang] [:jw_wang] from comment #15)
> The test case involes a special file where decoding errors will be
> encountered after decoding metadata. We test the duration when 'error' is
> fired.

Do you know how to generate that kind file?
Thanks!
Flags: needinfo?(jwwang)
No. Maybe kilik knows how to use ffmpeg to generate a file like that.
Flags: needinfo?(jwwang) → needinfo?(kikuo)
(Assignee)

Comment 18

2 years ago
I've found the file I need.
Flags: needinfo?(kikuo)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 22

2 years ago
Comment on attachment 8869298 [details]
Bug 1362793 - part2 : add test.

Add test.
Attachment #8869298 - Flags: review+ → review?(jwwang)

Comment 23

2 years ago
mozreview-review
Comment on attachment 8869298 [details]
Bug 1362793 - part2 : add test.

https://reviewboard.mozilla.org/r/140854/#review144416

::: dom/media/test/manifest.js:1510
(Diff revision 2)
>    }
>    is(!!test.keys, SpecialPowers.do_lookupGetter(e, "isEncrypted").apply(e),
>       msg + " isEncrypted should be true if we have decryption keys");
>  }
>  
> +function checkDuration(msg, e, test) {

Move this function into the .html since it has no other users.

::: dom/media/test/mochitest.ini:727
(Diff revision 2)
>  [test_decode_error.html]
>  [test_decoder_disable.html]
>  [test_defaultMuted.html]
>  [test_delay_load.html]
>  skip-if = android_version == '17' # android(bug 1232305)
> +[test_duration_check_after_error.html]

Call it test_duration_after_error.html
Attachment #8869298 - Flags: review?(jwwang) → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 26

2 years ago
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/940792ff8b54
part1 : shouldn't shutdown decoder too early. r=jwwang
https://hg.mozilla.org/integration/autoland/rev/8d2ae9e042aa
part2 : add test. r=jwwang

Comment 27

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/940792ff8b54
https://hg.mozilla.org/mozilla-central/rev/8d2ae9e042aa
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
33 failures in 777 pushes (0.042 failures/push) were associated with this bug in the last 7 days. 

This is the #40 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-central: 33

Platform breakdown:
* android-5-1-armv7-api15: 33

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1362793&startday=2017-05-15&endday=2017-05-21&tree=all
status-firefox-esr52: --- → unaffected
Whiteboard: [fennec-scouting] [stockwell needswork] → [fennec-scouting] [stockwell fixed:product]
You need to log in before you can comment on or make changes to this bug.