Mismatch in attachment pane - attachment shown for message without attachments.

RESOLVED WORKSFORME

Status

MailNews Core
Attachments
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: laurel, Unassigned)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using apr5 trunk on mac OS 9.2
Using apr8 trunk on linux rh6.2

On my IMAP account, I sent a messages having either one fairly large .gif
attachment and another message with multipe large image attachments (.jpg and
.gif).  I also sent another message with no attachments at all.  

When I opened the inbox, I selected one of the image attachment messages, but
before it downloaded, I selected the message without the attachment.  The
message without the attachment finished loading, its correct contents loaded in
the message pane, but the header envelope showed an attachment pane with the
attachment files from the other message.  If I switched  to another message and
back or open the message in a standalone, the message loaded properly and showed
no attachment pane.

Steps:

1.  Send a message to IMAP account having a couple fairly large image
attachments (300-500KB).  
2.  Send another message text only, no attachments to the imap account.
3.  Open the IMAP inbox, login, in 3-pane with message pane open.
4.  Select the message with attachments, but before it loads select the text
only message.  
5.  The attachment pane from the other message shows on the text only message.

Result:  The no-attachments message loads in the message pane properly, but its
header envelope shows an attachment pane listing the image files for the other
message.  Address, subj, date headers all appear correctly, but the attachment
pane is mismatched.
(Reporter)

Comment 1

16 years ago
Also happens on win98
Keywords: nsbeta1

Comment 2

16 years ago
Discussed in Mail News bug mtg with Engineering QA and PjM.  Decided to ADT3 and
plus this bug.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [ADT3]
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 4

16 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+
(Reporter)

Comment 5

16 years ago
*** Bug 156136 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
reproducable when using .csv files, other files seem to attach fine, some don't
(Reporter)

Comment 7

16 years ago
*** Bug 177705 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend

Comment 8

16 years ago
*** Bug 183421 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Updated

10 years ago
Assignee: mscott → nobody
QA Contact: stephend → attachments
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
WFM
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [ADT3]
You need to log in before you can comment on or make changes to this bug.