Closed Bug 1362923 Opened 4 years ago Closed 4 years ago

UnicodeDecodeError on non-US environment after landing VS2017 support

Categories

(Firefox Build System :: General, defect)

55 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1362872

People

(Reporter: m_kato, Unassigned)

References

Details

I found the following error during ./mach build.

 0:12.98 checking whether cross compiling... no
 0:13.12 Traceback (most recent call last):
 0:13.12   File "c:/Development/hg.mozilla.org/mozilla-central/configure.py", line 124, in <module>
 0:13.12     sys.exit(main(sys.argv))
 0:13.12   File "c:/Development/hg.mozilla.org/mozilla-central/configure.py", line 29, in main
 0:13.12     sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
 0:13.12   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 362, in run
 0:13.12     self._value_for(option)
 0:13.12   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 430, in _value_for
 0:13.12     return self._value_for_option(obj)
 0:13.12   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.12     cache[args] = self.func(instance, *args)
 0:13.14   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 447, in _value_for_option
 0:13.14     not self._value_for(implied_option.when)):
 0:13.14   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 427, in _value_for
 0:13.14     return self._value_for_depends(obj, need_help_dependency)
 0:13.14   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.14     cache[args] = self.func(instance, *args)
 0:13.14   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 436, in _value_for_depends
 0:13.14     return obj.result(need_help_dependency)
 0:13.14   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.16     cache[args] = self.func(instance, *args)
 0:13.16   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 153, in result
 0:13.16     return self._func(resolved_args)
 0:13.16   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 152, in <genexpr>
 0:13.16     for d in self.dependencies)
 0:13.16   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 427, in _value_for
 0:13.16     return self._value_for_depends(obj, need_help_dependency)
 0:13.16   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.17     cache[args] = self.func(instance, *args)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 436, in _value_for_depends
 0:13.17     return obj.result(need_help_dependency)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.17     cache[args] = self.func(instance, *args)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 106, in result
 0:13.17     for d in self.dependencies]
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 427, in _value_for
 0:13.17     return self._value_for_depends(obj, need_help_dependency)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.17     cache[args] = self.func(instance, *args)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 436, in _value_for_depends
 0:13.17     return obj.result(need_help_dependency)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.17     cache[args] = self.func(instance, *args)
 0:13.17   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 106, in result
 0:13.19     for d in self.dependencies]
 0:13.19   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 427, in _value_for
 0:13.19     return self._value_for_depends(obj, need_help_dependency)
 0:13.19   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.19     cache[args] = self.func(instance, *args)
 0:13.19   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 436, in _value_for_depends
 0:13.19     return obj.result(need_help_dependency)
 0:13.19   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.19     cache[args] = self.func(instance, *args)
 0:13.19   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 106, in result
 0:13.19     for d in self.dependencies]
 0:13.19   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 427, in _value_for
 0:13.20     return self._value_for_depends(obj, need_help_dependency)
 0:13.20   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.20     cache[args] = self.func(instance, *args)
 0:13.20   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 436, in _value_for_depends
 0:13.20     return obj.result(need_help_dependency)
 0:13.20   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.20     cache[args] = self.func(instance, *args)
 0:13.20   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 106, in result
 0:13.20     for d in self.dependencies]
 0:13.20   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 427, in _value_for
 0:13.20     return self._value_for_depends(obj, need_help_dependency)
 0:13.20   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.20     cache[args] = self.func(instance, *args)
 0:13.22   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 436, in _value_for_depends
 0:13.22     return obj.result(need_help_dependency)
 0:13.22   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\util.py", line 925, in method_call
 0:13.22     cache[args] = self.func(instance, *args)
 0:13.22   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 107, in result
 0:13.22     return self._func(*resolved_args)
 0:13.22   File "c:\Development\hg.mozilla.org\mozilla-central\python\mozbuild\mozbuild\configure\__init__.py", line 955, in wrapped
 0:13.22     return new_func(*args, **kwargs)
 0:13.22   File "c:/Development/hg.mozilla.org/mozilla-central/build/moz.configure/toolchain.configure", line 470, in vc_compiler_path
 0:13.22     all_versions = sorted(get_vc_paths(env.topsrcdir), key=itemgetter(0))
 0:13.22   File "c:/Development/hg.mozilla.org/mozilla-central/build/moz.configure/toolchain.configure", line 435, in get_vc_paths
 0:13.22     for install in vswhere(['-requires', 'Microsoft.VisualStudio.Component.VC.Tools.x86.x64']):
 0:13.22   File "c:/Development/hg.mozilla.org/mozilla-central/build/moz.configure/toolchain.configure", line 418, in vswhere
 0:13.22     return json.loads(subprocess.check_output([os.path.join(topsrcdir, 'build/win32/vswhere.exe'), '-format', 'json'] + args))
 0:13.22   File "c:\bin\python27\Lib\json\__init__.py", line 339, in loads
 0:13.23     return _default_decoder.decode(s)
 0:13.23   File "c:\bin\python27\Lib\json\decoder.py", line 364, in decode
 0:13.23     obj, end = self.raw_decode(s, idx=_w(s, 0).end())
 0:13.23   File "c:\bin\python27\Lib\json\decoder.py", line 380, in raw_decode
 0:13.23     obj, end = self.scan_once(s, idx)
 0:13.23 UnicodeDecodeError: 'utf8' codec can't decode byte 0x8f in position 0: invalid start byte
 0:13.23 *** Fix above errors and then restart with\
 0:13.23                "c:/mozilla-build/mozmake/mozmake.EXE -f client.mk build"
 0:13.23 c:/Development/hg.mozilla.org/mozilla-central/client.mk:379: recipe for target 'configure' failed
 0:13.23 mozmake.EXE[2]: *** [configure] Error 1
 0:13.23 c:/Development/hg.mozilla.org/mozilla-central/client.mk:396: recipe for target 'c:/Development/hg.mozilla.org/objdir-mc/config.status' failed
 0:13.23 mozmake.EXE[1]: *** [c:/Development/hg.mozilla.org/objdir-mc/config.status] Error 2
 0:13.23 client.mk:170: recipe for target 'build' failed
 0:13.23 mozmake.EXE: *** [build] Error 2
 0:13.31 303 compiler warnings present.


Since vswhere has multi-locale binary, description value is localized.

$ ./build/win32/vswhere.exe -requires Microsoft.VisualStudio.Component.VC.Tools.x86.x64 -format json

[
  {
    "instanceId": "877ff734",
    "installDate": "2017-03-08T08:11:02Z",
    "installationName": "VisualStudio/15.1.0+26403.7",
    "installationPath": "C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Professional",
    "installationVersion": "15.0.26403.7",
    "displayName": "Visual Studio Professional 2017",
    "description": "小規模なチーム向けのプロフェッショナルな開発者向けツールおよびサービス",
    "enginePath": "C:\\Program Files (x86)\\Microsoft Visual Studio\\Installer\\resources\\app\\ServiceHub\\Services\\Microsoft.VisualStudio.Setup.Service",
    "channelId": "VisualStudio.15.Release",
    "channelPath": "C:\\Users\\mkato\\AppData\\Local\\Microsoft\\VisualStudio\\Packages\\_Channels\\4CB340F5\\catalog.json",
    "channelUri": "https://aka.ms/vs/15/release/channel",
    "releaseNotes": "https://go.microsoft.com/fwlink/?LinkId=660090#15.1.26403.07",
    "thirdPartyNotices": "https://go.microsoft.com/fwlink/?LinkId=660105"
  }
]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362872
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.