Installation fails with error message "Seamonkey requires Microsoft Windows 7 or newer"

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
7 months ago
7 months ago

People

(Reporter: DaLiV, Unassigned)

Tracking

SeaMonkey 2.50 Branch
Unspecified
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213183751

Steps to reproduce:

try to install any nightly builds of seamonkey /think also TB anf FF same problem have/ for example 2.51 on XP or Vista PCs


Actual results:

message with meaning "You MUST PAY to microsoft for new windows" appears


Expected results:

must working

Are microsoft managers here appears ? why opensource product must run only on newest OS-es 
as "you should PAY to microsoft for their new OS versions" is quite in controversy how FSF positioned self

... to whom MS is payed for abandoning of mozilla products on old OS for theirs further profit ?
(Reporter)

Updated

7 months ago
Version: SeaMonkey 2.46 Branch → Trunk
(Reporter)

Comment 1

7 months ago
Last installable is
seamonkey-2.49a2.en-US.win32.installer.exe from 23-Jan-2017 12:08

Comment 2

7 months ago
Mozilla dropped support of WIN XP and WIN vista with FF 53, and SeaMonkey has no resources (and IMHO no interest) in holding support for those outdated operation systems. 

But that is a very strange, impertinent error message. Really caused by SM?

@Reporter:
Please contribute a Screenshot of that error message and step by step instruction due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines> to find out in which step the error message comes up.
Flags: needinfo?(daliv.tyw)
OS: Unspecified → Windows XP
Summary: Why Abandoned XP/Vista installation and usage? → Installation fails with error message "you should PAY to microsoft for their new OS versions"
Version: Trunk → SeaMonkey 2.50 Branch
(Reporter)

Comment 3

7 months ago
Step by step - start installation from installer https://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/seamonkey-2.52a1.en-US.win32.installer.exe
will get message (EXACT)
Sorry, 'SeaMonkey' can't be installed. This version of 'SeaMonkey' requires Microsoft Windows 7 or newer. Please click the OK button for additional information.

exact message is ..."Seamonkey requires Microsoft Windows 7 or newer"...
but MEANING of this - Buy new Windows ... 

what low level functions of windows really used by mozilla products, that block to compile and install for older windows versions ? suppose answer is "fast none" ... may be something with visualization accelerator related, which may be compiled conditionally ... but for what ??? /if maintainer is payed by MS and own MSDN versions of newest OS-es/ ... more simpler way throw many users, that will not buy every year new PC with new OS ... as also cannot switch to that as used some other specific softwares/that will not running on new windows versions/

i'm quite sure that problem is more organizational, than real coding issues, as also sure that count of features that is not crossplatform and rely on some dll, that persist only in latest windows is equal to 0 (unlike main functionality, that is realized for all platforms)
Flags: needinfo?(daliv.tyw)

Updated

7 months ago
Summary: Installation fails with error message "you should PAY to microsoft for their new OS versions" → Installation fails with error message "Seamonkey requires Microsoft Windows 7 or newer"

Comment 4

7 months ago
Yeah, that's Mozilla Core code, thus we don't really have much influence on it. There will be no 2.50 release, what you are using is a nightly build. Releases will come from the 52 ESR branch, thus still work on Windows XP and Vista for about a year.

As for the message, we *could* modify it in suite/locales/en-US/installer/windows/custom.properties (WARN_MIN_SUPPORTED_OSVER_MSG), but I don't see the point in making it "Please buy a new version" given that it's a generic message and not all operating systems (or specific versions for that matter) require payment. Thus, there doesn't appear to be any suitable alternative wording for that message.

Feel free to reopen as a core bug, but I don't expect the Firefox people to be sympathetic to this...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
The main reason was imho that the ICU libraries dropped support for XP and Vista and it also becomes more and more problematic to support such old versions. No debugger support and more and more workarounds for non existing or broken apis need to be implemented. I still use XP myself but in this case I can fully understand the reason to discontinue support. As rsx11m stated the 2.49 line will support XP for at least another year. 

The meassage is the same one Firefox uses and should not be changed.
You need to log in before you can comment on or make changes to this bug.