Request WebExtensions API equivalent to nsiLoginManager

RESOLVED DUPLICATE of bug 1344788

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1344788
8 months ago
4 months ago

People

(Reporter: blk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
I use an extension - Keychain Services Integration - that makes heavy use of the nsiLoginManager API to store Firefox's passwords in the Mac OS X Keychain (the Keychain is the Mac OS X system password manager).

I'd like to request that WebExtensions equivalent of the API could be implemented, such that this extension could live on as a WebExtension.

Comment 1

8 months ago
Please look also at https://bugzilla.mozilla.org/show_bug.cgi?id=1324919

Is nsILoginManagerStorage also needed as webext API for keychain storage?
(Reporter)

Comment 2

8 months ago
> Is nsILoginManagerStorage also needed as webext API for keychain storage?

It definitely is needed, yes.

Looking over the extension, I *think* it works by creating a nsILoginManagerStorage instance (for Keychain interfacing), then supplying its own versions of all of nsiLoginManager's methods that will work with the new Storage instance.
(Reporter)

Comment 3

8 months ago
OK, so it looks like I'm not the only person to bring this up - see https://bugzilla.mozilla.org/show_bug.cgi?id=1344788 for another bug requesting implementation of a nsILoginManagerStorage equivalent.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344788

Comment 5

4 months ago
[Tracking Requested - why for this release]:
status-firefox57: --- → ?
status-firefox58: --- → ?
tracking-firefox57: --- → ?
tracking-firefox58: --- → ?
status-firefox57: ? → ---
status-firefox58: ? → ---
tracking-firefox57: ? → ---
tracking-firefox58: ? → ---
You need to log in before you can comment on or make changes to this bug.