Implement browsingData.remove WebExtension API method on android

RESOLVED FIXED in Firefox 57

Status

enhancement
P5
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: shatur, Assigned: shatur, Mentored)

Tracking

(Blocks 1 bug)

unspecified
mozilla57
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [triaged])

Attachments

(1 attachment)

This method removes the specified browsing data. The doc can be found at [1].

[1]. https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/browsingData/remove
Blocks: 1362118
Priority: -- → P5
Whiteboard: [triaged]
Hey Shane!

Would it be suitable if I resolve the issue you mentioned at [1], here??

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1362998#c15
Flags: needinfo?(mixedpuppy)
Assignee: nobody → tushar.saini1285
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to Tushar Saini (:shatur) from comment #2)
> Hey Shane!
> 
> Would it be suitable if I resolve the issue you mentioned at [1], here??
> 
> [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1362998#c15

I'd prefer a followup bug to remove that since schema can handle it.
Flags: needinfo?(mixedpuppy)
Comment on attachment 8898673 [details]
Bug 1363014 - Implement browsingData.remove WebExtension API method on android.

https://reviewboard.mozilla.org/r/170058/#review178676

This looks good. Nice work, Tushar.
Attachment #8898673 - Flags: review?(bob.silverberg) → review+
Comment on attachment 8898673 [details]
Bug 1363014 - Implement browsingData.remove WebExtension API method on android.

https://reviewboard.mozilla.org/r/170058/#review178966
Attachment #8898673 - Flags: review?(s.kaspari) → review+
Attachment #8898673 - Flags: review?(mixedpuppy)
Comment on attachment 8898673 [details]
Bug 1363014 - Implement browsingData.remove WebExtension API method on android.

https://reviewboard.mozilla.org/r/170058/#review180164
Attachment #8898673 - Flags: review?(mixedpuppy) → review+
Flags: needinfo?(s.kaspari)
Flags: needinfo?(s.kaspari)
Pushed by s.kaspari@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/213fe035b50b
Implement browsingData.remove WebExtension API method on android. r=bsilverberg,mixedpuppy,sebastian
https://hg.mozilla.org/mozilla-central/rev/213fe035b50b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.