recent osx opt BBB change turned off new talos perf-reftest job

RESOLVED FIXED in mozilla55

Status

Taskcluster
Task Configuration
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: jmaher, Assigned: kmoir)

Tracking

unspecified
mozilla55

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
when bug 1358188 landed, the T(p) job failed to be run anymore:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=osx%20perf-reftest&fromchange=af9a92eb3203ed0f36b7dbb5a64b2af9b25f7f27

I would really like to fix this ASAP or backout since we will be losing coverage, especially when a merge takes place.
(Assignee)

Comment 1

10 months ago
Created attachment 8865558 [details] [diff] [review]
bug1363101.patch

I think this will fix it
Attachment #8865558 - Flags: review?(jmaher)
(Reporter)

Comment 2

10 months ago
Comment on attachment 8865558 [details] [diff] [review]
bug1363101.patch

Review of attachment 8865558 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for the quick patch!
Attachment #8865558 - Flags: review?(jmaher) → review+
(Assignee)

Updated

10 months ago
Assignee: nobody → kmoir

Comment 3

10 months ago
Pushed by kmoir@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/431279b0ac7b
recent osx opt BBB change turned off new talos perf-reftest job r=jmaher DONTBUILD
(Reporter)

Comment 4

10 months ago
do we have a fix for beta?  we are pushing to try with beta sources and unable to get osx jobs running?
Flags: needinfo?(kmoir)
(Assignee)

Comment 5

10 months ago
The patches from bug 1363101 haven't landed on beta yet, I think this is the issue.  wcosta: are there plans to uplift the patches from bug 1363101 to m-b?
Flags: needinfo?(kmoir) → needinfo?(wcosta)

Comment 6

10 months ago
It looks like comment 5 is referring to this bug.  Are you referring to a patch from another bug?
(Reporter)

Comment 7

10 months ago
I could be referring to the wrong thing, please help me figure out what is not working for the scenario when pushing beta to try and running osx builds and tests jobs.
(Assignee)

Comment 8

10 months ago
Sorry, I meant bug 1358188 in comment 5.  The issue is that jmaher is trying to run talos tests on m-b on try.  However, the changes to schedule the tests + talos via taskcluster have not landed on m-b yet.  This change has been enabled for try.
I assume this applies to ESR52 as well? I pushed that to Try today and didn't get the requested OSX tests either.
Do we have link for the try push?
Flags: needinfo?(wcosta)
(Reporter)

Comment 11

10 months ago
this is the try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4aeff94a7fc872e4716def28f89647fd0d0b4488

we manually did a 'add new job' to get the osx tasks running (and the buildbot build)
(In reply to Joel Maher ( :jmaher) from comment #11)
> this is the try push:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=4aeff94a7fc872e4716def28f89647fd0d0b4488
> 
> we manually did a 'add new job' to get the osx tasks running (and the
> buildbot build)

Something seems outdated, should not have an opt cross compiled build...
(Reporter)

Comment 13

10 months ago
that is a push from beta sources (not trunk/etc.) where the buildbot scheduling stuff has (not) landed?
(In reply to Joel Maher ( :jmaher) from comment #13)
> that is a push from beta sources (not trunk/etc.) where the buildbot
> scheduling stuff has (not) landed?

I just checked beta and esr52, neither have the patches uplifted. We need uplift patches for bug 1358188 and bug 1350413.

Comment 15

10 months ago
bug 1362949 probably needs uplifted too

Comment 16

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/431279b0ac7b
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Comment 17

10 months ago
verified that this test is not working on th.
(Assignee)

Comment 18

10 months ago
last comment should have been *now* working on treeherder
Will patches for bugs 1358188, 1350413, 1362949 and 1363714 will be uplifted to esr52 and beta?
Flags: needinfo?(kmoir)
Flags: needinfo?(jmaher)
I can take a crack at that.
(Reporter)

Comment 21

10 months ago
those look like the right bugs.  beta for sure, I would say esr52 as well.
(Reporter)

Updated

10 months ago
Flags: needinfo?(jmaher)
Just took a look at this and hit conflicts on the first commit :(. Bug 1350413 rev 971b9548d84c touches taskcluster/taskgraph/morph.py, which only exists on 55+. Looks like there's going to have to be some significant patch reworking here or a lot more uplifts :\
(In reply to Ryan VanderMeulen [:RyanVM] from comment #22)
> Just took a look at this and hit conflicts on the first commit :(. Bug
> 1350413 rev 971b9548d84c touches taskcluster/taskgraph/morph.py, which only
> exists on 55+. Looks like there's going to have to be some significant patch
> reworking here or a lot more uplifts :\

These are patches I think we need: bug 1333255, bug 1347569, bug 1347889 and bug 1353456. In that order.
So, after some chat in #taskcluster, best thing is to add new patches to disable the tests that don't apply to beta and esr52, and then uplift everything inside taskcluster/. :jmaher, do you know which tests we should disable in beta and esr52?
Flags: needinfo?(kmoir) → needinfo?(jmaher)
(Reporter)

Comment 25

10 months ago
for beta- what new tests are enabled in 55 vs 54
for esr- what new tests are enabled in 55 vs 52

These I don't know, but upon some initial looking I see:
unique to m-c - T(p) T-e10s(p)
unique to beta - runs Wr, M(gl1 gl2 gl3), R(J1 J2 R) W(1 2 3 4 5)  <- NOTE: mostly we are missing non-e10s tests on m-c


for esr-52:
unique to m-c - R(J2) T(*) T-e10s(*) <- no talos on esr, and only 1 jsreftest chunk!!
unique to beta - runs Wr, M(gl1 gl2 gl3), R(J R) W(1 2 3 4 5)  <- NOTE: mostly we are missing non-e10s tests on m-c


I think those are the differences- did we accidentally turn of mochitest-webgl non-e10s on osx opt for trunk?  Same for web-platform-tests?  I honestly don't think we should re-enable them if it was an accident.
Flags: needinfo?(jmaher)
You need to log in before you can comment on or make changes to this bug.